[Algorithm] Dynamic Programming--hdu1503 Advanced Fruit (LCS)

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4356    Accepted Submission(s): 2284
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
 
  
apple peach ananas banana pear peach
 

Sample Output
 
  
appleach bananas pearch


    Topic Analysis:

    For the longest substring problem, note that the output is a set of substrings.

    Code:

// dp--LCS
// Dynamic programming -- longest common substring

#include<iostream>
#include<cstring> //memset
#include<stdio.h>

using namespace std;
const int MAX=100+1;

int dp[MAX][MAX]; //length
int visit[MAX][MAX]; //mark 1: oblique up 2: up 3: left
int lenS1,lenS2;
char s1[MAX],s2[MAX]; //Pay attention to the definition of strings


void LCS()
{
	// initialize
	memset(dp,0,sizeof(dp));
	for(int i=0;i<=lenS1;i++)
		visit[i][0]=0;
	for(int j=0;j<=lenS2;j++)
		visit[0][j]=0;
	// Comparison  
	for(int i=1;i<=lenS1;i++)
		for(int j=1;j<=lenS2;j++)
		{
			if(s1[i-1]==s2[j-1])
			{
				dp[i][j]=dp[i-1][j-1]+1;
				visit[i][j]=1;
			}
			else {
			
				if(dp[i-1][j] >= dp[i][j-1])
				{
					dp[i][j]=dp[i-1][j];
					visit[i][j]=2;
				}
				else
				{
					dp[i][j]=dp[i][j-1];
					visit[i][j]=3;
				}
			}
		}
	
}

void print_LCS(int i,int j)
{
	if(i==0 && j==0)  	return ;
	if(visit[i][j]==1)
	{
		print_LCS(i-1,j-1);
		cout<<s1[i-1];
	}
	else if(visit[i][j]==2)
	{
		print_LCS(i-1,j);
		cout<<s1[i-1];
	}
	else if(visit[i][j]==3)
	{
		print_LCS(i,j-1);
		cout<<s2[j-1];
		
	}
	else if(visit[i][j]==0 && j==0 && i>0)
	{
		print_LCS(i-1,j);
		cout<<s1[i-1];
		
	}
		else if(visit[i][j]==0 && i==0 && j>0)
	{
		print_LCS(i,j-1);
		cout<<s2[j-1];
		
	}
	
}

intmain()
{
//	freopen("2.txt","r",stdin);
//	freopen("3.txt","w",stdout);
	while(~scanf("%s%s",s1,s2))
	{
		lenS1=strlen(s1);
		lenS2=strlen(s2);
		LCS();
		print_LCS(lenS1,lenS2);
		cout<<endl;
	}
	
	return 0;
}
 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324645574&siteId=291194637