POJ -1144 Network Find the cut point

                                      Network

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is  
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure  
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated  
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;
Output
The output contains for each block except the last in the input file one line containing the number of critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0
Sample Output
1
2
Hint
You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

A sufficient condition for point u to be a cut point:

1.  If u is the root of the dfs tree, then u has at least two children.

2.  If u is not the root of the dfs tree, it has at least one child w. Starting from w, it is impossible to reach the ancestor of u through the back edge connected to the descendants of w and w.

The necessary and sufficient conditions for u to be a cut point are: u is either the root of a depth-first spanning tree with more than two children, or, although it is not a root, it has a child w such that low[w]>=dfn[u ].
The dfn array is the record time from the root of the dfs to traverse the nodes of the tree. The second condition roughly means that the children of u must pass through u to reach the ancestors of u (nodes close to the root).

code show as below:


   
/* POJ 1144*/


#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
#include<stack>
#include<list>
#include<set>
#define manx maxn
const int maxn = 100 +10;
using namespace std;
int times,roots,cnt;
int Next[maxn*200],To[maxn*200],Lext[maxn],vis[manx],dis[manx];
int dfn[manx],low[manx];
void init()
{
    times=roots=cnt=0;
    memset(Next,0,sizeof(Next));
    memset(Lext,0,sizeof(Lext));
    memset(To,0,sizeof(To));
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
}
void add(int u,int v)
{
    Next[++cnt]=Lext[u];
    To[cnt]=v;
    Lext[u]=cnt;
}
int dfs(int u)
{
    int cntn=0;
    dfn[u]=low[u]=++times;
    vis[u]=1;
    for(int i=Lext[u]; i; i=Next[i])
    {
        int v=To[i];
        if(!dfn[v])
        {
            cntn++;
            dfs(v);
            low[u]=min(low[u],low[v]);
            if(u==roots&&cntn==2)
                dis[u]=1;
            if(u!=roots&&low[v]>=dfn[u])
                dis[u]=1;
        }
        else if(vis[v])//这里的意思 就是v点已经访问了 v点是u点的祖先 及v到u有回边
        {
           low[u]=min(low[u],dfn[v]);
        }
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)==1&&n)
    {
        int a,b;
        int i,ans=0;
        char c;
        init();
        while(scanf("%d",&a)==1&&a)
        {
            while((c=getchar())!='\n')
            {
                scanf("%d",&b);
                add(a,b);
                add(b,a);
            }
        }//这里懵了好久 输入有点坑
        times=0;
        roots=1;
        dfs(roots);
        for(i=1; i<=n; i++)
            if(dis[i])ans++;
        printf("%d\n",ans);
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=326304414&siteId=291194637