Shortest path

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and R
Lines 2…R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
邻接表

#include<stdio.h>
#define inf 1010110
int dis1[6000];
int dis2[6000];
int head[6000];
int vis[6000][2];
struct node
{
    
    
    int to;
    int next;
    int w;
}q[1001011];
int cnt=0;
void add(int x,int y,int z)
{
    
    
    q[cnt].to=y;
    q[cnt].w=z;
    q[cnt].next=head[x];
    head[x]=cnt++;
}
int main()
{
    
    
    int n,m,x,y,z,i,j,minn,pare,u,k;
    scanf("%d %d",&n,&m);
    for(i=1;i<=n;i++)
    {
    
    
        dis1[i]=inf;
        dis2[i]=inf;
        head[i]=-1;
        vis[i][0]=0;
        vis[i][1]=0;
    }
    for(i=0;i<m;i++)
    {
    
    
        scanf("%d %d %d",&x,&y,&z);
        add(x,y,z);
        add(y,x,z);
    }
    dis1[1]=0;
    for(i=0;i<=n*2;i++)
    {
    
    
        minn=inf;
        for(j=1;j<=n;j++)
        {
    
    
            if(vis[j][0]==0&&minn>dis1[j])
            {
    
    
                pare=0;
                u=j;
                minn=dis1[j];
            }
            else  if(vis[j][1]==0&&minn>dis2[j])
            {
    
    
                pare=1;
                u=j;
                minn=dis2[j];
            }
        }
        if(minn==inf)
            break;
        vis[u][pare]=1;
        for(k=head[u];k!=-1;k=q[k].next)
        {
    
    
            int a=q[k].w;
            int b=q[k].to;
            if(dis1[b]>(minn+a))
            {
    
    
                dis2[b]=dis1[b];
                dis1[b]=minn+a;
            }
            else if((minn+a)<dis2[b]&&dis1[b]<(minn+a))
            {
    
    
                dis2[b]=minn+a;
            }
        }
    }
    printf("%d\n",dis2[n]);
}

Guess you like

Origin blog.csdn.net/m0_46312382/article/details/113103763