Bone Collector HDU-2602 (01 backpack problem solving report)

Bone Collector
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?``
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1 5
10 1 2 3 4 5 5 4 3 2 1

Sample Output
14

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 1e5 + 10;
int w[maxn], c[maxn],dp[maxn];/////w[i]表示骨头的体积,c[i]表示骨头的价值
int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		memset(dp, 0, sizeof(dp));
		int n, V;
		scanf("%d%d", &n, &V);
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &c[i]);
		}
		for (int i = 1; i <= n; i++)
		{
			scanf("%d", &w[i]);
		}		
		for (int i = 1; i <= n; i++)
		{
			for (int v = V; v >= w[i]; v--)
				dp[v] = max(dp[v], dp[v - w[i]] + c[i]);////状态转移方程
		}
		printf("%d\n", dp[V]);
	}
	return 0;
}
Published 7 original articles · praised 0 · visits 67

Guess you like

Origin blog.csdn.net/weixin_45629285/article/details/105589138