1.BFD Introduction 2. Static routing calls BFD 3.OSPF call call BFD BFD 4.VRRP

BFD

1.BFD Introduction 2. Static routing calls BFD 3.OSPF call call BFD BFD 4.VRRP

BFD: Bidirectional Forwarding Detection Bidirectional Forwarding check

Action: troubleshooting millisecond, usually in combination Layer protocols (e.g., static routing, VRRP, OSPF, BGP, etc.) to achieve a quick check of a link failure.

1.BFD Introduction 2. Static routing calls BFD 3.OSPF call call BFD BFD 4.VRRP

FIG 1: R1 R2 a route to 2.2.2.2 There are two lines, high above the link bandwidth, the routing take the above route,

However, when one side of a fault line R2, then R1 can not be timely sensing line failure, so a BFD quick check can be completed within the switching circuit milliseconds.

1. Check the static BFD

1.BFD Introduction 2. Static routing calls BFD 3.OSPF call call BFD BFD 4.VRRP

# R1 configuration

[Huawei]sysnam R1

[R1]inteface Ethernet0/0/1

[R1-Ethernet0/0/1]ip address 21.1.1.10 255.255.255.0

[R1-Ethernet0/0/1]quit

[R1]interface Ethernet0/0/0

[R1-Ethernet0/0/0]ip address 12.1.1.10 255.255.255.0

[R1-Ethernet0/0/0]quit

[R1]interface loopback 0

[R1-loopback0]ip address 1.1.1.1 32

[R1-loopback0]quit

[R1]bfd

[R1-bfd]quit

[R1]bfd 1 bind peer-ip 12.1.1.11 source-ip 12.1.1.10

[R1-bfd-session-1]discriminator local 2

[R1-bfd-session-1]discriminator remot 1

[R1-bfd-session-1]commit

[R1-bfd-session-1]quit

[R1]

[R1]ip route-static 2.2.2.2 32 21.1.1.11

[R1]ip route-static 2.2.2.2 32 12.1.1.11 pre 55 track bfd-session 1

# R2 configuration

[Huawei]sysnam R2

[R2] inteface Ethernet0 / 0/1 // enter the interface

[R2-Ethernet0 / 0/1] ip address 21.1.1.11 255.255.255.0 // Configure IP addresses

[R2-Ethernet0/0/1]quit

[R2]interface Ethernet0/0/0

[R2-Ethernet0/0/0]ip address 12.1.1.11 255.255.255.0

[R2-Ethernet0/0/0]quit

[R2]interface loopback 0

[R2-loopback0]ip address 2.2.2.2 32

[R2-loopback0]quit

[R2] bfd // enable BFD globally

[R2-bfd]quit

[R2] bfd 1 bind peer-ip 12.1.1.1 0 source-ip 12.1.1.11. // Create a BFD process 1

[R2-bfd-session-1] discriminator local 1 // local ID, identification needs two routers symmetric to each other

[R2-bfd-session-1] discriminator remot 2 // distal end is

[R2-bfd-session-1] commit // submitted BFD Configuration

[R2-bfd-session-1]quit

[R2]ip route-static 1.1.1.1 32 21.1.1.10

[R2] ip route-static 1.1.1.1 32 12.1.1.10 pre 55 track bfd-session 1 // static call routing at BFD

[R2]

# R10 view the configuration of BFD

<R10>display bfd session static


Local Remote PeerIpAddr State Type InterfaceName


1               2                    12.1.1.11                  Up                  S_IP_PEER -

Total UP/DOWN Session Number : 1/0

<R10>

View detailed configuration of BFD on # R10

<R10>display bfd session static verbose


Session MIndex : 256 (Multi Hop) State : Up Name : 1


Local Discriminator : 1 Remote Discriminator : 2

Session Detect Mode : Asynchronous Mode Without Echo Function

BFD Bind Type : Peer IP Address

Bind Session Type : Static

Bind Peer IP Address : 12.1.1.11

Bind Interface : -

Track Interface : -

Bind Source IP Address : 12.1.1.10

FSM Board Id : 0 TOS-EXP : 7

Min Tx Interval (ms) : 1000 Min Rx Interval (ms) : 1000

Actual Tx Interval (ms): 1000 Actual Rx Interval (ms): 1000

Local Detect Multi : 3 Detect Interval (ms) : 3000

Echo Passive : Disable Acl Number : -

Destination Port : 3784 TTL : 254

Proc Interface Status : Disable Process PST : Disable

WTR Interval (ms) : -

Active Multi : 3

Last Local Diagnostic : No Diagnostic

Bind Application : No Application Bind

Session TX TmrID : - Session Detect TmrID : -

Session Init TmrID : - Session WTR TmrID : -

Session Echo Tx TmrID : -

PDT Index : FSM-0 | RCV-0 | IF-0 | TOKEN-0

Session Description : -


Total UP/DOWN Session Number : 1/0

<R10>

2. Dynamic BFD: OSPF BFD call to accelerate the convergence

1.BFD Introduction 2. Static routing calls BFD 3.OSPF call call BFD BFD 4.VRRP

# R1 configuration

[R1]interface Ethernet0/0/0

[R1-Ethernet0/0/0]ip address 12.1.1.1 24

[R1-Ethernet0/0/0]quit

[R1]interface Loopback0

[R1-loopback0]ip address 1.1.1.1 255.255.255.255

[R1-loopback0]quit

[R1] router id 1.1.1.1 // router Router-ID

[R1] ospf 10 // open the OSPF process 10

[R1-ospf-10] area 0 // The OSPF area 10 0

[R1-ospf-10-0.0.0.0] network 12.1.1.0 0.0.0.255 / / route announcement at the region 0 OSPF10

[R1-ospf-10-0.0.0.0]network 1.1.1.1 0.0.0.0

[R1-ospf-10-0.0.0.0]quit

[R1-ospf-10]quit

[R1] bfd // Enable global BFD check

[R1-bfd]quit

[R1] ospf 10 // The OSPF process 10

[R1-ospf-10] bfd all-interfaces enable // open at BFD for OSPF

[R1-ospf-10]quit

[R1]

# R2 configuration

[R2]interface Ethernet0/0/0

[R2-Ethernet0/0/0]ip address 12.1.1.1 24

[R2-Ethernet0/0/0]quit

[R2] interface Loopback0 // back into the ring opening

[R2-loopback0] ip address 1.1.1.1 255.255.255.255 // port loopback address configure

[R2-loopback0]quit

[R2]router id 1.1.1.1

[R2]ospf 10

[R2-ospf-10]area 0

[R2-ospf-10-0.0.0.0]network 12.1.1.0 0.0.0.255

[R2-ospf-10-0.0.0.0]network 1.1.1.1 0.0.0.0

[R2-ospf-10-0.0.0.0]quit

[R2-ospf-10]quit

[R2] bfd // check the global enable BFD

[R2-bfd]quit

[R2] ospf 10 // 10 into the process of OSPF

[R2-ospf-10]bfd all-interfaces enable

[R2-ospf-10]quit

[R2]

# R10 under dynamic display of BFD neighbor

<R10>display bfd session dynamic


Local Remote PeerIpAddr State Type InterfaceName


8192 8192 21.1.1.11 Up D_IP_IF GigabitEthernet0/0/0

8193 8193 12.1.1.11 Up D_IP_IF GigabitEthernet0/0/1


Total UP/DOWN Session Number : 2/0

<R10>

For more information on the configuration of BFD # R10

<R10>display bfd session all verbose


Session MIndex : 257 (One Hop) State : Up Name : dyn_8192


Local Discriminator : 8192 Remote Discriminator : 8192

Session Detect Mode : Asynchronous Mode Without Echo Function

BFD Bind Type : Interface(GigabitEthernet0/0/0)

Bind Session Type : Dynamic

Bind Peer IP Address : 21.1.1.11

NextHop Ip Address : 21.1.1.11

Bind Interface : GigabitEthernet0/0/0

FSM Board Id : 0 TOS-EXP : 7

Min Tx Interval (ms) : 1000 Min Rx Interval (ms) : 1000

Actual Tx Interval (ms): 1000 Actual Rx Interval (ms): 1000

Local Detect Multi : 3 Detect Interval (ms) : 3000

Echo Passive : Disable Acl Number : -

Destination Port : 3784 TTL : 255

Proc Interface Status : Disable Process PST : Disable

WTR Interval (ms) : -

Active Multi : 3

Last Local Diagnostic : No Diagnostic

Bind Application : OSPF

Session TX TmrID : - Session Detect TmrID : -

Session Init TmrID : - Session WTR TmrID : -

Session Echo Tx TmrID : -

PDT Index : FSM-0 | RCV-0 | IF-0 | TOKEN-0

Session Description : -



Session MIndex : 258 (One Hop) State : Up Name : dyn_8193


Local Discriminator : 8193 Remote Discriminator : 8193

Session Detect Mode : Asynchronous Mode Without Echo Function

BFD Bind Type : Interface(GigabitEthernet0/0/1)

Bind Session Type : Dynamic

Bind Peer IP Address : 12.1.1.11

NextHop Ip Address : 12.1.1.11

Bind Interface : GigabitEthernet0/0/1

FSM Board Id : 0 TOS-EXP : 7

Min Tx Interval (ms) : 1000 Min Rx Interval (ms) : 1000

Actual Tx Interval (ms): 1000 Actual Rx Interval (ms): 1000

Local Detect Multi : 3 Detect Interval (ms) : 3000

Echo Passive : Disable Acl Number : -

Destination Port : 3784 TTL : 255

Proc Interface Status : Disable Process PST : Disable

WTR Interval (ms) : -

Active Multi : 3

Last Local Diagnostic : No Diagnostic

Bind Application : OSPF

Session TX TmrID : - Session Detect TmrID : -

Session Init TmrID : - Session WTR TmrID : -

Session Echo Tx TmrID : -

PDT Index : FSM-1 | RCV-0 | IF-0 | TOKEN-0

Session Description : -


Total UP/DOWN Session Number : 2/0

<R10>

3.VRRP linkage BFD

Topology topology

Specifically located:

# R10 Configuration

[R10] interface GigabitEthernet0 / 0/0 // enter the interface GigabitEthernet0 / 0/0

[R10-GigabitEthernet0 / 0/0] ip address 21.1.1.10 255.255.255.0 // Configure IP addresses

[R10-GigabitEthernet0 / 0/0] quit // Exit Interface

[R10]bfd

[R10-bfd]quit

[R10] bfd 5 bind peer-ip 112.1.1.12 source-ip 112.1.1.10 // configure static BFD-5

[R10-bfd-session-5] discriminator local 100 // 100 configure the local values

[R10-bfd-session-5] discriminator remote 200 // 200 disposed distal values

[R10-bfd-session-5] commit // submitted BFD Configuration

[R10-bfd-session-5]quit

[R10]bfd bb bind peer-ip 112.1.1.12 source-ip 112.1.1.10 auto

[R10-bfd-session-bb]quit

[R10]

[R10]interface GigabitEthernet0/0/1

[R10-GigabitEthernet0/0/1]ip address 12.1.1.10 255.255.255.0

[R10-GigabitEthernet0/0/1]vrrp vrid 10 virtual-ip 12.1.1.1

[R10-GigabitEthernet0/0/1]vrrp vrid 10 priority 105

[R10-GigabitEthernet0 / 0/1] vrrp vrid 10 track bfd-session 100 // VRRP BFD100 local call identifier of the BFD

[R10-GigabitEthernet0/0/1]quit

[R10]interface loopback 0

[R10-loopback0]ip address 10.10.10.10 255.255.255.25

[R10-loopback0]quit

[R10]

# R11 configuration

[R11]interface GigabitEthernet0/0/0

[R11-GigabitEthernet0/0/0]ip address 21.1.1.11 255.255.255.0

[R11-GigabitEthernet0/0/0]quit

[R11]interface GigabitEthernet0/0/1

[R11-GigabitEthernet0/0/1]ip address 12.1.1.11 255.255.255.0

[R11-GigabitEthernet0/0/1]vrrp vrid 10 virtual-ip 12.1.1.1

[R11-GigabitEthernet0/0/1]quit

[R11]interface loopback 0

[R11-loopback0]ip address 11.11.11.11 255.255.255.25

[R11-loopback0]quit

[R11]

# R12 configuration

[R12]interface GigabitEthernet0/0/0

[R12-GigabitEthernet0/0/0]ip address 112.1.1.12 255.255.255.0

[R12-GigabitEthernet0/0/0]quit

[R12]

[R12]bfd 5 bind peer-ip 112.1.1.12 source-ip 112.1.1.10

[R12-bfd-session-5] discriminator local 200 // Local identifier configured BFD

[R12-bfd-session-5] discriminator remote 100 // remote configuration identification BFD

[R12-bfd-session-5] commit // configuration submitted BFD

[R12-bfd-session-5]quit

[R12] bfd bb bind peer-ip 112.1.1.10 source-ip 112.1.1.12 auto // automatic detection mechanism configured BFD

[R12]interface loopback 0

[R12-loopback0]ip address 12.12.12.12 255.255.255.255

[R12-loopback0]quit

[R12]

View BFD session on R10

[R10]display bfd session all


Local Remote PeerIpAddr State Type InterfaceName


8192 8192 21.1.1.11 Up D_IP_IF GigabitEthernet0/0/0

8193 8193 12.1.1.11 Up D_IP_IF GigabitEthernet0/0/1

100 200 112.1.1.12 Up S_IP_PEER -


Total UP/DOWN Session Number : 3/0

[R10]

View VRRP Configuration (VRRP priorities change after a broken link) on # R10

<R10>display vrrp

GigabitEthernet0/0/1 | Virtual Router 10

State : Backup

Virtual IP : 12.1.1.1 Master IP : 12.1.1.11

PriorityRun : 95 PriorityConfig : 105
MasterPriority : 100 Preempt : YES Delay Time : 0 s

TimerRun : 1 s TimerConfig : 1 s

Auth type : NONE Virtual MAC : 0000-5e00-010a

Check TTL : YES Config type : normal-vrrp

Backup-forward : disable Track BFD : bb Priority reduced : 10

BFD-session state : DOWN Create time : 2020-03-29 14:35:24 UTC-08:00

Last change time : 2020-03-29 15:29:32 UTC-08:00

<R10>

# R10 after the peer link reply priority

<R10>display vrrp

GigabitEthernet0/0/1 | Virtual Router 10

State : Master

Virtual IP : 12.1.1.1 Master IP : 12.1.1.10

PriorityRun : 105 PriorityConfig : 105
MasterPriority : 105 Preempt : YES Delay Time : 0 s

TimerRun : 1 s TimerConfig : 1 s

Auth type : NONE Virtual MAC : 0000-5e00-010a

Check TTL : YES Config type : normal-vrrp

Backup-forward : disable Track BFD : bb Priority reduced : 10

BFD-session state : UP Create time : 2020-03-29 14:35:24 UTC-08:00

Last change time : 2020-03-29 15:37:00 UTC-08:00

<R10>

Note: VRRP BFD Linkage: If the associated VRRP typically have layer two device isolation, can now be achieved by means of BFD failure detection.

Guess you like

Origin blog.51cto.com/dfsshan/2483770
bfd
BFD
BFD