Catch That Cow


Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 115041   Accepted: 35968

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:   N  and   K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutës.


#include<iostream>
#include<stdlib.h>
#include<string>
#include<queue>
#include<stdio.h>
#include<string.h>
using namespace std;
int y;
int v[200005]={0};
int f[3][2]={2,0,1,-1,1,1};
struct node{
	int x,t;
};
void bfs(int x,int t)
{

	node s;
    queue <node> q;
    s.x=x;
    s.t=t;
    v[x]=1;
    q.push(s);
    while(!q.empty())
    {	
		
    	s=q.front();
		q.pop();
		
    	if(s.x==y)
    	{
    		cout<<s.t<<endl; 
    		break;
		}
    
    	for(int i=0;i<3;i++)
		{
			int xx=s.x*f[i][0]+f[i][1];
		  
			if(xx>=0&&xx<=200001&&v[xx]==0)
			{
			
				v[xx]=1;
				node ss;
				ss.t=s.t+1;
				ss.x=xx;
				q.push(ss);
			}
		}
	}
}
int main()
{
	int x;
	while(~scanf("%d%d",&x,&y))
	{
	    memset(v,0,sizeof(v));
		bfs(x,0);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_38570571/article/details/81029330