POJ 2010 Moo University - Financial Aid 二分答案

I - Moo University - Financial Aid

 
Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input
* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 
Output
* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 
Sample Input
3 5 70
30 25
50 21
20 20
5 18
35 30
Sample Output
35
Hint
Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 

这道题是如何想到二分的呢? 首先我们想到钱要满足 那么对钱排个序 同样对分数排个序 

选一个分数作为中间分数 并检查他前面和后面有没有N/2个数即可

然后从代码分析四种跳出情况

但是要注意score 和 aid数组差别蛮大的

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#define MAX_COW 1000000+16
#define dbg(x) cout<<#x<<" = "<< (x)<< endl


int N,C,F;
struct COW {
    int rank_by_score;
    int score;
    int aid;
}cow_score[MAX_COW],cow_aid[MAX_COW];
bool less_by_score(COW a,COW b){
    return a.score < b.score;
}
bool less_by_aid(COW a,COW b){
    return a.aid< b.aid;
}


int main(){
   ios::sync_with_stdio(false);
   cin >> N >>C >> F;
   int half = N/2;
   for(int i= 1;i<=C;++i)
    cin>> cow_score[i].score >> cow_score[i].aid ;
   sort(cow_score+1,cow_score+1+C,less_by_score);
   for(int i=1;i<=C;++i)
     cow_score[i].rank_by_score = i;
   memcpy(cow_aid,cow_score,sizeof(COW)*(C+1));
   sort(cow_aid+1,cow_aid+C+1,less_by_aid);
   int lx = 1,rx = C,ans = -1;
   while(lx<=rx){
    int mid_x = (lx+rx)/2;
    int total_left = 0,total_right = 0,total_aid = cow_score[mid_x].aid;
     for(int i=1;i<=C;++i){
          if((cow_aid[i].rank_by_score<mid_x)&&((total_aid+cow_aid[i].aid)<=F)&&(total_left<N/2)){
            ++total_left;
            total_aid+=cow_aid[i].aid;
        }
        else if((cow_aid[i].rank_by_score>mid_x)&&(total_aid+cow_aid[i].aid<=F)&&(total_right<N/2)){
                   ++total_right;
            total_aid+=cow_aid[i].aid;
        }
     }
       if((total_left<N/2)&&(total_right<N/2)){
        ans = -1;
        break;
       }
       else if(total_left<N/2){
        lx = mid_x+1;
       }
       else if(total_right<N/2){
        rx = mid_x-1;
       }
       else {
        ans = cow_score[mid_x].score;
        lx=mid_x+1;
       }
   }
       cout << ans <<endl;
   return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80608835