Financial Management(poj 1004)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_25203255/article/details/78904453

1 问题描述

Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

大致意思

求12个月的工资的平均值

题目地址poj 1004

2 算法思路

很简单,获取输入累加除12输出即可,需要注意的是结果要考虑四舍五入(题目要求)

3 算法实现

#include <iostream>
#include <iomanip>

using namespace std;

int main()
{
    double val, sum = 0.0;
    int i;
    for(i = 0; i < 12; ++i) {
        cin >> val;
        sum += val;
    }
    // 结果只取小数点后2位,并四舍五入
    cout<< fixed << setprecision(2) << '$' << sum/12 <<endl;
    return 0;
}

4 数据测试


这里写图片描述

猜你喜欢

转载自blog.csdn.net/qq_25203255/article/details/78904453