Balancing Act POJ - 1655(树形dp)

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1…N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:
在这里插入图片描述

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.
Input
The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.
Output
For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.
Sample Input
1
7
2 6
1 2
1 4
4 5
3 7
3 1
Sample Output
1 2
思路:一道树形dp的简单题目。对于这个节点来说,它的distance有可能是在子树中产生,也有可能是在父节点的一端产生。dp数组记录的是这个节点的子树中的总节点数,num数组记录的是这个节点子树中最长的距离。然后dfs一遍就可以了。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;

const int maxx=2e4+100;
struct edge{
	int to,next;
}e[maxx<<1];
int head[maxx<<1],dp[maxx],num[maxx];
int n,tot;

inline void init()
{
	memset(head,-1,sizeof(head));
	for(int i=1;i<=n;i++) dp[i]=num[i]=0;
	tot=0;
}
inline void add(int u,int v)
{
	e[tot].next=head[u],e[tot].to=v,head[u]=tot++;
}
inline int dfs(int u,int f,int &_min,int &pos)
{
	dp[u]=1;
	for(int i=head[u];i!=-1;i=e[i].next)
	{
		int to=e[i].to;
		if(to==f) continue;
		dp[u]+=dfs(to,u,_min,pos);
		num[u]=max(num[u],dp[to]);
	}
	num[u]=max(num[u],n-dp[u]);
	if(num[u]<_min)
	{
		_min=num[u];
		pos=u;
	}
	return dp[u];
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		init();
		int x,y;
		for(int i=1;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			add(x,y);
			add(y,x);
		}
		int _min=inf;
		int pos;
		dfs(1,0,_min,pos);
		
		printf("%d %d\n",pos,_min);
	}
	return 0;
}

努力加油a啊,(o)/~

发布了673 篇原创文章 · 获赞 128 · 访问量 6万+

猜你喜欢

转载自blog.csdn.net/starlet_kiss/article/details/105655030