Greedy binary heap / disjoint-set

Training 4 - A title

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ
x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4 50 2 10 1 20 2 30 1

7 20 1 2 1 10 3 100 2 8 2
5 20 50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Method 1:

#pragma warning (disable:4996)
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#define inf 0X7f7f7f7f
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e4 + 10;

struct Good
{
	int p;
	int d;
};
priority_queue<Good> q;
bool operator<(Good x, Good y)
{
	return x.p > y.p;
}

Good s[maxn];
bool cmp(Good x, Good y)
{
	return x.d < y.d;
}

int n, ans;

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		ans = 0;
		for (int i = 1; i <= n; i++)
			scanf("%d%d", &s[i].p, &s[i].d);
		sort(s + 1, s + n + 1, cmp);
		for (int i = 1; i <= n; i++)
			if (q.size() == s[i].d)
			{
				if (q.empty() || s[i].p > q.top().p)
				{
					q.pop();
					q.push(s[i]);
				}
			}
			else if (q.size() < s[i].d)
				q.push(s[i]);
				while (!q.empty())
		{
			ans += q.top().p;
			q.pop();
		}
		printf("%d\n", ans);
	}
	return 0;
}

Ideas:
greedy, every day to sell the most profitable to sell the commodity currently.
The goods from small to large order in accordance with the expiration time into an array, while maintaining a top of the heap is the maximum profit commodity binary heap.
Through the array, if no time is expired, you can sell the merchandise into the stack; if the current time expired goods, (since commodities are within the stack before that time can be sold), the before replacing the most profitable commodity.
Thus, the binary heap rest of the commodity is the ability to sell merchandise.

Method 2:

#pragma warning (disable:4996)
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define inf 0X3f3f3f3f
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e4 + 5;

int fa[maxn];//天数

void initial(int n)
{
	for (int i = 1; i <= n; i++)
	{
		fa[i] = i;
	}
}

int get(int x)
{
	if (x == fa[x])
		return x;
	return fa[x] = get(fa[x]);
}

void merge(int x, int y)
{
	fa[get(x)] = get(y);
}

struct Good
{
	int p;
	int d;
};
Good s[maxn];
bool cmp(Good x, Good y)
{
	return x.p > y.p;
}
int n, ans;
bool v[maxn];

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		ans = 0;
		int day = 0;
		for (int i = 1; i <= n; i++)
		{
			scanf("%d%d", &s[i].p, &s[i].d);
			day = max(day, s[i].d);
		}
		sort(s + 1, s + n + 1, cmp);
		initial(day);
		for (int i = 1; i <= n; i++)
		{
			int t = get(s[i].d);
			if (t > 0)
			{
				ans += s[i].p;
				fa[t] = get(t - 1);
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

Ideas:
greedy, priority to sell the largest commodity profits, and sell the latest time, it will eventually be able to get the maximum profit.
With disjoint-set to maintain the number of days, we will have to sell commodities consecutive time in one collection. In this way, every time and can be set to find the latest time check unsold goods.

Published 28 original articles · won praise 0 · Views 322

Guess you like

Origin blog.csdn.net/xukeke12138/article/details/104822771