Max Sum(dp)

Problem Description
Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

Author
Ignatius.L

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring> 
using namespace std;
int dp[100000][4];
//0是值,1是dp,2是起点,3是终点 
int main(){
	int t,n;
	cin>>t;
	for(int j=1;j<=t;j++){
		memset(dp,0,sizeof(dp));
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			scanf("%d",&dp[i][0]);
			dp[i][1]=dp[i][0];
			dp[i][2]=i;
			dp[i][3]=i;
		}
		for(int i=2;i<=n;i++){
			if(dp[i-1][1]+dp[i][1]>=dp[i][1]){
				dp[i][1]+=dp[i-1][1];//总和++ 
				dp[i][2]=dp[i-1][2];//起点等于上一个的起点 
			}
		}
		cout<<"Case "<<j<<":"<<endl;
		int max=-9999999;
		for(int i=1;i<=n;i++){
			if(max<=dp[i][1])max=dp[i][1];
		}
		for(int i=1;i<=n;i++){
			if(max==dp[i][1]){
				cout<<dp[i][1]<<" "<<dp[i][2]<<" "<<dp[i][3]<<endl;
				break;
			}
		}
		if(j!=t)cout<<endl;
	}
	return 0;
}

It is to determine the optimal solution for each position, the state transition equation

if(dp[i-1][1]+dp[i][1]>=dp[i][1]){
	dp[i][1]+=dp[i-1][1];//总和++ 
	dp[i][2]=dp[i-1][2];//起点等于上一个的起点 
}
Published 10 original articles · won praise 1 · views 483

Guess you like

Origin blog.csdn.net/xuhang513/article/details/104685264