HDU 1024 Max Sum Plus Plus (base dp)

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34541    Accepted Submission(s): 12341


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1 , S 2 , S 3 , S 4  ... S x , ... S n  (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x  ≤ 32767). We define a function sum(i, j) = S i  + ... + S j  (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1 , j 1 ) + sum(i 2 , j 2 ) + sum(i 3 , j 3 ) + ... + sum(i m , j m ) maximal (i x  ≤ i y  ≤ j x  or i x  ≤ j y  ≤ j x  is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x , j x )(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S 1 , S 2 , S 3  ... S n .
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

 

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

 

Author
JGShining
 

 

Recommend
We have carefully selected several similar problems for you:   1074  1025  1081  1080  1160 
 
 
The meaning of the question: Give us an array of length N and let us divide the array into M strings that we do not want to intersect so that the sum of the M strings is the largest
#include <iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define MAXN 1100000
#define INF 0x3f3f3f3f
int dp[MAXN];
int maxn[MAXN];
int a[MAXN];
int main()
{
    int n,m;
    std::ios::sync_with_stdio(false);
    while(cin>>m>>n){
        for(int i=1;i<=n;i++){
                cin>>a[i];
                maxn[i]=0;
                dp[i]=0;
        }
        dp[0]=0;
        maxn[0]=0;
        int maxx;
        for(int i=1;i<=m;i++){
                 maxx=-INF;
                for(int j=i;j<=n;j++){
                        dp[j]=max(dp[j-1]+a[j],maxn[j-1]+a[j]);
                        maxn[j-1]=maxx;
                        maxx=max(maxx,dp[j]);
                }
        }
        cout<<maxx<<endl;
    }
    return 0;
}

 

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325147380&siteId=291194637