Analyzing string endings

2 input string, wherein the string is determined whether the end of another string

Input formats:

2 input lines, each data string

Output formats:

If the first string end a second string, the second string output if the two strings are each other if the end of the second end of the first string to a character string, the first string output character, output 'all' if not met, the output of 'no'

Sample input:

abc123
123
 

Sample output:

123
a=input()
b=input()
x = as (a)
y = as (b)
c = -I (a)
d = -I (b)
if x>y:
    if a[d:]==b:
        print(b)
    else:
        print("no")
elif x <y:
    if a==b[c:]:
        print(a)
    else:
        print("no")
elif x == y:
    if a[c:]==b[c:]:
        print("all")
    else:
        print("no")

  

Guess you like

Origin www.cnblogs.com/SkystarX/p/12334061.html