PAT Grade -1032-Sharing (linked list traversal)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.
Here Insert Picture Description

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
analysis:

Here Insert Picture Description

  • As traversing and traversing the linked list, the need to design a flag variable, that the tags for each node is visited node.
  • What is the same node? in factThe node address is the same as the same node. What is the common node? which isAfter traversing the two chains words, two nodes visited

code show as below

#include<iostream>
using namespace std;
struct NODE{
	char c;
	int next;
	bool visit; 
}node[100000];
int main()
{
	int addr1,addr2,n,cur,next;
	char data;
	scanf("%d%d%d", &addr1,&addr2, &n);
	for(int i = 0; i < n; i++){
		scanf("%d %c %d", &cur, &data, &next);
		node[cur]={data,next,false};
	}
	for(int i = addr1; i != -1; i = node[i].next){
		node[i].visit = true;
	}
	for(int i = addr2; i != -1; i = node[i].next){
		if(node[i].visit==true){
			printf("%05d", i);return 0;
		}
		node[i].visit = true;
	}
	printf("-1\n");
	return 0;
}
Published 110 original articles · won praise 746 · views 30000 +

Guess you like

Origin blog.csdn.net/qq_42437577/article/details/104182422