[POJ 1417 --- True Liars] kind of disjoint-set + DP + back backpack

[POJ 1417 --- True Liars] kind of disjoint-set + DP + back backpack

Topic Source: Click to enter [POJ 2236 - Wireless Network]

Description

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell.

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie.

He asked some of them whether or not some are divine. They knew one another very much and always responded to him “faithfully” according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy since everyone living on this island is immortal and none have ever been born at least these millennia.

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries.

Input

The input consists of multiple data sets, each in the following format :

n p1 p2
xl yl a1
x2 y2 a2
...
xi yi either
...
xn is an

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi can be the same number since “are you a member of the divine tribe?” is a valid question. Note also that two lines may have the same x’s and y’s since Akira was very upset and might have asked the same question to the same one more than once.

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e., if a given data set does not include sufficient information to identify all the divine members, print no in a line.

Sample Input

2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output

no
no
1
2
end
3
4
5
6
end

Problem-solving ideas

By analyzing the meaning of problems known: Enter the x, y, yes behalf of x, y certain kind, enter the x, y, no table with x, y is definitely not the same.
So we can easily imagine the kind of disjoint-set, rk [x] represents the relationship between x and its parent node, rk [x] = 0 x represents his father belong to the same node, rank [x] = 1 x represent nodes belonging to his father heterogeneous; by disjoint-set will be able to determine the relative relationship between a set of numbers in which each number of binding which can be divided into two parts, and the root node of the same type of metal, as well as the root node and nodes belong to heterogeneous;

We determined the number of nodes and the number of different number of nodes, the root node and each set of inside and dividing the collection of the same kind; then select a node from a portion corresponding to the set of (or all sets) which, if all the selected nodes p1 is the sum of the number of unique selection method, we can determine the number of all the angels, not vice versa; dp method on how the election is something we can use knapsack problem can be the perfect solution;

To mark the number of nodes of the i-th value of j is set by arr [i] [j].
DP is represented by [i] [j] to select the type of the i-th set is j and the total number of methods, i.e., dp [num] [p1] == 1 is enabled the answer is determined;
and then determining which nodes back.

AC Code:

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 605;
int pre[MAXN],rk[MAXN],cnt[MAXN],arr[MAXN][2],dp[MAXN][MAXN],lj[MAXN][MAXN];
bool ans[MAXN][2];

void init(int n)
{
    memset(rk,0,sizeof(rk));
    memset(cnt,0,sizeof(cnt));
    memset(arr,0,sizeof(arr));
    memset(dp,0,sizeof(dp));
    memset(lj,0,sizeof(lj));
    memset(ans,false,sizeof(ans));
    for(int i=0;i<=n;i++)
        pre[i]=i;
}

int _find(int x)
{
    if(x==pre[x]) return x;
    int p=pre[x];
    pre[x]=_find(pre[x]);
    rk[x]=rk[x]^rk[p];
    return pre[x];
}

void unite(int a,int b,int c)
{
    int x=_find(a);
    int y=_find(b);
    if(x==y) return;
    pre[x]=y;
    rk[x]=rk[a]^rk[b]^c;
}

int main()
{
    SIS;
    int n,p1,p2,x,y,pos;
    string s;
    while(cin >> n >> p1 >> p2, n+p1+p2)
    {
        pos=p1+p2;
        init(pos);
        for(int i=0;i<n;i++)
        {
            cin >> x >> y >> s;
            if(s[0]=='y') unite(x,y,0);
            else unite(x,y,1);
        }
        int num=0;
        for(int i=1;i<=pos;i++)
            if(pre[i]==i) cnt[i]=++num;
        for(int i=1;i<=pos;i++)
            arr[cnt[_find(i)]][rk[i]]++;
        dp[0][0]=1;
        for(int i=1;i<=num;i++)
        {
            x=min(arr[i][0],arr[i][1]);
            for(int j=p1;j>=x;j--)
            {
                if(dp[i-1][j-arr[i][0]])
                    dp[i][j]+=dp[i-1][j-arr[i][0]],lj[i][j]=arr[i][0];
                if(dp[i-1][j-arr[i][1]])
                    dp[i][j]+=dp[i-1][j-arr[i][1]],lj[i][j]=arr[i][1];
            }
        }
        if(dp[num][p1]!=1) { cout << "no" << endl; continue;}
        for(int i=num,j=p1;i>0;i--)
        {
            if(lj[i][j]==arr[i][0]) ans[i][0]=true;
            else ans[i][1]=true;
            j-=lj[i][j];
        }
        for(int i=1;i<=pos;i++)
            if(ans[cnt[_find(i)]][rk[i]]) 
                cout << i << endl;
        cout << "end" << endl;
    }
    return 0;
}
Published 412 original articles · won praise 135 · views 40000 +

Guess you like

Origin blog.csdn.net/qq_41879343/article/details/104164119