[POJ 2236 --- Wireless Network] disjoint-set

[POJ 2236 --- Wireless Network] disjoint-set

Topic Source: Click to enter [POJ 2236 - Wireless Network]

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. “O p” (1 <= p <= N), which means repairing computer p.
  2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Problem-solving ideas

Every fix a computer when he traversed it all repaired computer, to see whether the distance <= d, if the explanation can be connected in line with the set of merger where two computers.
Every check the time to determine what if both computers to the same collection.

AC Code:

#include <iostream>
#include <algorithm>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 1e3+5;
int pre[MAXN],arr[MAXN];

struct Node
{
    int x,y;
}node[MAXN];

void init()
{
    for(int i=0;i<MAXN;i++)
        pre[i]=i;
}

int _find(int x)
{
    if(x==pre[x]) return x;
    return pre[x]=_find(pre[x]);
}

void unite(int x,int y)
{
    x=_find(x);
    y=_find(y);
    if(x!=y) pre[x]=y;
}

int dis(Node &x,Node &y)
{
    return (x.x-y.x)*(x.x-y.x)+(x.y-y.y)*(x.y-y.y);
}

int main()
{
    SIS;
    int n,d;
    init();
    cin >> n >> d;
    for(int i=1;i<=n;i++)
        cin >> node[i].x >> node[i].y;
    char ch;
    int num=0,x,y;
    while(cin >> ch)
    {
        if(ch=='O')
        {
            cin >> x;
            arr[num++]=x;
            for(int i=0;i<num-1;i++)
                if(dis(node[arr[i]],node[x])<=d*d)
                    unite(arr[i],x);
        }
        else
        {
            cin >> x >> y;
            if(_find(x)==_find(y)) cout << "SUCCESS" << endl;
            else cout << "FAIL" << endl;
        }
    }
    return 0;
}
Published 412 original articles · won praise 135 · views 40000 +

Guess you like

Origin blog.csdn.net/qq_41879343/article/details/104162598