PAT A1073 Scientific Notation (20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [±][1-9].[0-9]+E[±][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.
Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E + 10

Sample Output 2:

-12000000000

Meaning of the questions:

A given number of scientific notation represented, general representation of the number is determined.

Ideas:

(1) represents a set pos 'E' position, exp denotes the set value of the exponent;
(2) sub-pos + 1 == '-' or pos + 1 == '+' two cases discussed: a first '' the case where the first output '0.', exp-1 and then output a '0', the final output is not numeric string; the second case need to discuss the two cases: case1: coefficient of less than decimals length (exp portion < '.' pos-3) , while the digital output is not at the position of the string output of exp + 2, case2 '.': exp> '.' = pos-3, the first digital output is not string, and then outputs exp- (pos-3) a '0'.

Code:

#include <cstdio>
#include <cstring>
int main(){
	char str[99999];
	scanf("%s",str);
	int len=strlen(str); 
	if(str[0]=='-')
		printf("-");
	int pos=1;//'E'的位置
	for(int i=1;i<len;i++){
		if(str[i]!='E')
			pos++;
		else
			break;
	} 
	int exp=0;//系数的值
	for(int i=pos+2;i<len;i++){
		exp=exp*10+(str[i]-'0');
	}
	if(str[pos+1]=='-'){
		printf("0.");
		for(int i=0;i<exp-1;i++){
			printf("0");
		}
		for(int i=1;i<pos;i++){
			if(i==2)continue;
			printf("%c",str[i]);
		}
	}else{
		if(exp<pos-3){
			for(int i=1;i<pos;i++){
				if(i==2)continue;
				printf("%c",str[i]);
				if(i==exp+2)
					printf(".");
			}
		}else{
			for(int i=1;i<pos;i++){
				if(i==2)continue;
				printf("%c",str[i]);
			}
			for(int i=0;i<exp-(pos-3);i++){
				printf("0");
			} 
		}
	} 
	return 0;
}

vocabulary:

notation notation
real Number Real
trailing dragging

PS:

?

Published 26 original articles · won praise 0 · Views 479

Guess you like

Origin blog.csdn.net/PanYiAn9/article/details/102644724