HDU 2879 HeHe (multiplicative function primes +)

Description:

In the equation X 2 X ( m o d N ) X^2≡X(mod N) where x [ 0 , N 1 ] x∈[0,N-1] , we define He[N] as the number of solutions.
And furthermore, define H e H e [ N ] = H e [ 1 ] H e [ N ] HeHe[N]=He[1]*……*He[N]
Now here is the problem, write a program, output HeHe[N] modulo M for a given pair N , M N, M .

Input

First line: an integer t t , representing t t test cases.
Each test case contains two numbers N ( 1 < = N < = 1 0 7 ) N (1<=N<=10^7) and M ( 0 < M < = 1 0 9 ) M (0<M<=10^9) separated by a space.

Output

For each test case, output one line, including one integer: H e H e [ N ] m o d m HeHe[N] mod m .

Sample Input

1
2 3

Sample Output

2

Meaning of the questions:

definition H e [ x ] He[x] 为当 x [ 0 , N 1 ] x∈[0,N−1] satisfies X 2 X ( m o d N ) X^2≡X(modN) solution number, seeking H e He before n n entry product, the mold m m
law own push:
Here Insert Picture Description
can be found H e H e [ N ] HeHe [N] is equal to 2 2 less than n n multiple of the number of power and a prime only.

AC Code:

#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
	int ret = 0, sgn = 1;
	char ch = getchar();
	while (ch < '0' || ch > '9')
	{
		if (ch == '-')
			sgn = -1;
		ch = getchar();
	}
	while (ch >= '0' && ch <= '9')
	{
		ret = ret * 10 + ch - '0';
		ch = getchar();
	}
	return ret * sgn;
}
inline void Out(int a) //Êä³öÍâ¹Ò
{
	if (a > 9)
		Out(a / 10);
	putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
	return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
	return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(int m, int k, int mod)
{
	ll res = 1, t = m;
	while (k)
	{
		if (k & 1)
			res = res * t % mod;
		t = t * t % mod;
		k >>= 1;
	}
	return res;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
	return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
	if (b == 0)
	{
		x = 1;
		y = 0;
		return a;
	}
	int g = exgcd(b, a % b, x, y);
	int t = x;
	x = y;
	y = t - a / b * y;
	return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
	int d, x, y;
	d = exgcd(a, p, x, y);
	if (d == 1)
		return (x % p + p) % p;
	else
		return -1;
}

///中国剩余定理模板
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
	int M = 1, y, x = 0;
	for (int i = 0; i < n; ++i) //算出它们累乘的结果
		M *= a[i];
	for (int i = 0; i < n; ++i)
	{
		int w = M / a[i];
		int tx = 0;
		int t = exgcd(w, a[i], tx, y); //计算逆元
		x = (x + w * (b[i] / t) * x) % M;
	}
	return (x + M) % M;
}

int n, m;
const int N = 1e7 + 10;
bool vis[N];
int prime[N], cnt;
void prim()
{
	cnt = 0;
	for (int i = 2; i <= N - 10; i++)
	{
		if (!vis[i])
		{
			prime[cnt++] = i;
			for (int j = i * 2; j <= N - 10; j += i)
				vis[j] = 1;
		}
	}
	return;
}

int main()
{
	mem(vis, 0);
	prim();
	int t;
	sd(t);
	while (t--)
	{
		sdd(n, m);
		ll sum = 0;
		for (int i = 0; i < cnt && prime[i] <= n; i++)
		{
			sum += n / prime[i];
		}
		ll ans = qpow(2, sum, m);
		pld(ans);
	}
	return 0;
}

Published 611 original articles · won praise 390 · Views 200,000 +

Guess you like

Origin blog.csdn.net/qq_43627087/article/details/103952435