1096 Consecutive Factors (20分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2^​31).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

Ideas:

Find a number n of all of the factors which the longest string of continuous factors. i traversing from 2, if i is a factor of n (n% i == 0), then start looking for i from successive strings factor update max_len. Note that factor does not exceed the maximum sqrt (n).
If max_len is 0, then n is 2 or described prime number, the maximum length of a continuous factors.

Source:

#include<bits/stdc++.h>
using namespace std;
vector<int> factor,answer;
int max_len=0;
int main()
{
    int n;
    cin>>n;
    for(int i=2;i<=sqrt(n);i++)
    {
        if(n%i==0)
        {
            int t=n/i;
            int num=1;
            factor.clear();
            factor.push_back(i);
            if(num>max_len)
            {
                max_len=num;
                answer=factor;//将answer中的内容全部删除,复制为factor
            }
            for(int j=i+1;j<sqrt(n)&&t%j==0;j++)
            {
                num++;
                t/=j;
                factor.push_back(j);
                if(num>max_len)
                {
                    max_len=num;
                    answer=factor;//将answer中的内容全部删除,复制为factor
                }
            }
        }
    }

    if(!max_len)
        cout<<"1\n"<<n<<endl;
    else{
        cout<<max_len<<endl;
        int f=1;
        for(vector<int>::iterator itor=answer.begin();itor!=answer.end();itor++)
        {
            if(f)
            {
                cout<<*itor;
                f=0;
            }
            else
                cout<<"*"<<*itor;
        }
    }
}
Published 97 original articles · won praise 12 · views 2402

Guess you like

Origin blog.csdn.net/weixin_43301333/article/details/104080146