1036 Boys vs Girls (25分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F−gradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

Sex-order table is divided into two, respectively, girl sort boy.

Source:

#include<bits/stdc++.h>
#define Max 1010
using namespace std;
typedef struct student{
    string name;
    string id;
    int score;
}stu;
vector<stu> girl;
vector<stu> boy;
bool compare(stu a,stu b)
{
    return a.score>b.score;//降序
}
int main()
{
    int n;cin>>n;
    for(int i=0;i<n;i++)
    {
        stu t;char c;
        cin>>t.name;
        getchar();//吸收空格
        c=getchar();
        cin>>t.id>>t.score;
        if(c=='F')
            girl.push_back(t);
        else
            boy.push_back(t);
    }

    sort(girl.begin(),girl.end(),compare);
    sort(boy.begin(),boy.end(),compare);

    if(!girl.size())
        cout<<"Absent"<<endl;
    else
        cout<<girl[0].name<<" "<<girl[0].id<<endl;
    if(!boy.size())
        cout<<"Absent"<<endl;
    else
        cout<<(boy.end()-1)->name<<" "<<(boy.end()-1)->id<<endl;

    if(girl.size()&&boy.size())
        cout<<girl[0].score-(boy.end()-1)->score<<endl;
    else
        cout<<"NA"<<endl;
}
Published 97 original articles · won praise 12 · views 2392

Guess you like

Origin blog.csdn.net/weixin_43301333/article/details/104097958