PTA(Advanced Level)1036.Boys vs Girls

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeFgradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA
Thinking
  • Before with PTA (Basic Level) 1028. Census is still a bit like, but here the situation compared to men and women. But more content is a fraction, compared to the previous count and a simple
Code
#include<bits/stdc++.h>
using namespace std;
struct student
{
    char name[20];
    char gender;
    char id[20];
    int grade;
}female_high, male_low;

void Init()
{
    female_high.grade = -1;
    male_low.grade = 110;
}

bool higher(student a, student b)
{
    return a.grade > b.grade;
}

int main()
{
    int n;
    Init();
    scanf("%d", &n);
    student tmp;
    while(n--)
    {
        scanf("%s %c %s %d", tmp.name, &tmp.gender, tmp.id, &tmp.grade);
        if(tmp.gender == 'M' && higher(male_low, tmp))
            male_low = tmp;
        if(tmp.gender == 'F' && higher(tmp, female_high))
            female_high = tmp;
    }

    bool absent = false;
    if(female_high.grade == -1)
    {
        printf("Absent\n");
        absent = true;
    }else printf("%s %s\n", female_high.name, female_high.id);
    if(male_low.grade == 110)
    {
        printf("Absent\n");
        absent = true;
    }else printf("%s %s\n", male_low.name, male_low.id);
    if(absent)
        printf("NA");
    else printf("%d", female_high.grade - male_low.grade);
    return 0;
}
Quote

https://pintia.cn/problem-sets/994805342720868352/problems/994805453203030016

Guess you like

Origin www.cnblogs.com/MartinLwx/p/11665090.html