Algorithm notes on combat training aircraft Beginners Guide Chapter 4 (2) - 4.1 sorting algorithm preliminary study notes

PAT B1015 moral theory (25 points) / A1062

Song Dynasty historian Sima Guang, there is a famous "moral theory" in the "Mirror": "The actual occurrence of that of the saints to do the whole virtuous, virtuous and death that of a fool, Ruby was that of a gentleman, just Shengde that of the villain. people who take the surgery, Gou not saints, and with the gentleman, was its villain, was not as fools. "

Now gives moral and scores a number of candidates, please give admission ranked according to Sima Guang theory.

Input formats:

Input of the first line gives three positive integers, respectively: N ( ≤), i.e., the total number of candidates; L ( ≥), the lowest score for candidate, i.e., not lower than Caifen de points and  L candidates eligible to be consider admission; H ( <), priority admission line - not Caifen de points and below this line is defined as "the whole virtuous do", such candidates listed in the order according to the moral and out; but not assigned de Caifen line candidates belonging to a class of "Ruby only", and sorted by score, but behind the first category candidates; moral points were lower than  H, but less than the minute before de candidates points are "dead virtuous and" still "Ruby only" person, sorted by score, but behind the second type but candidates; other low line  L also candidates sorted out, but they appear after the third category candidates.

Then  N rows, each row gives information of an examinee, comprising: 准考证号 德分 才分wherein 准考证号an 8-bit integer, integer divided moral interval [0, 100] within. Between numbers separated by a space.

Output formats:

Firstly, a first output line to reach the minimum score of the number of candidates to  M, then  M rows, each row in accordance with the output of an input format candidates, the candidates according to the rules listed in the order of the input instructions. When there is more than certain candidates out of the same, in descending order according to their de points; if de points also tied in ascending order of the output ticket number.

Sample input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct student{
    char id[10];
    int de,cai,sum;
    int flag; //分类 
}stu[100010];
bool cmp(student a,student b){
    if(a.flag != b.flag ) 
        return a.flag < b.flag;
    else if(a.sum != b.sum) 
        return a.sum > b.sum;
    else if(a.de != b.de) 
        return a.de > b.de;
    else
        return strcmp(a.id,b.id) < 0;
}
int main(){
    int N,L,H;
    scanf("%d%d%d",&N,&L,&H);
    int m = N;
    for(int i=0;i<N;i++){
        scanf("%s %d %d",stu[i].id,&stu[i].de,&stu[i].cai);
        this [the] .sum = this [i] + .de this [the] .cai;
        if (this [the] .de <L || this [the] .cai < L) {
            stu[i].flag = 5;
            m--;
        }else if(stu[i].de>=H && stu[i].cai >= H){
            stu[i].flag = 1;
        }else if(stu[i].de >= H && stu[i].cai < H){
            stu[i].flag = 2;
        } Else  if (this [the] .de> = this [the] .cai) {
            stu[i].flag = 3;
        }else{
            stu[i].flag = 4;
        }
    }
    sort(stu,stu+N,cmp);
    printf("%d\n",m);
    for(int i = 0;i<m;i++){
        printf("%s %d %d\n",stu[i].id,stu[i].de,stu[i].cai);
    }

    return 0;
}
PAT A1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90 310102 70 95 88 84 310103 82 87 94 88 310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A C M E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct Student{
    int id;
    int score[4];
}stu[2010];
int now;
int Rank[1000000][4]={0};
char course[4]= {'A','C','M','E'};
bool cmp(Student a,Student b){
    return a.score[now] > b.score[now];
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++){
        scanf("%d %d %d %d",&stu[i].id,&stu[i].score[1],&stu[i].score[2],&stu[i].score[3]);
        stu[i].score[0] = round((stu[i].score[1] + stu[i].score[2] + stu[i].score[3])/3.0);
    }
    for(now=0;now<4;now++){
        sort(stu,stu+n,cmp);
        Rank[stu[0].id][now] = 1;
        for(int i=1;i<n;i++){
            if(stu[i].score[now] == stu[i-1].score[now]){
                Rank[stu[i].id][now] = Rank[stu[i-1].id][now];
            }else{
                Rank[stu[i].id][now] = i + 1;
            }
        }
    }
    for(int i=0;i<m;i++){
        int query;
        scanf("%d",&query);
        if(Rank[query][0] == 0){
            printf("N/A\n");
        }else{
            int k=0;
            for(int j=0;j<4;j++){
                if(Rank[query][j] < Rank[query][k]){
                    k = j;
                }
            }
            printf("%d %c\n",Rank[query][k],course[k]);
        }
    }
    return 0;
}

 

 

Guess you like

Origin www.cnblogs.com/coderying/p/12233615.html