Phalanx HDU2859(dp)

Phalanx

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4581 Accepted Submission(s): 2144

Problem Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size nn, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3
3 symmetrical matrix:
cbx
cpb
zcc

Input
There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.

Explanation

I thought to dp [i] [j] to submatrix as the maximum (i, j) of the bottom left side of the sub-matrix size.
Transfer equation DP [I] [J] = min (CONT, DP [i-1] [j + 1]) +. 1;
CONT to walk from (i, j) to i-1 and j + 1 in both directions through how many elements are matched groups (not including the (i, j) that itself.
side length new maximum sub-matrix depends on the maximum edge length to (i-1, j + 1 ) matrix and the lower left corner cont that small.
ans select dp greatest results, note that when the scale is not updated when 1 ans, ans so assigned an initial value of 1.
If the limit then a small space, you can scroll dp array is one-dimensional array.

Sample Input
3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output
3
3

#include <cstdio>
#include <cstring>
#include <algorithm>
int const maxn = 1e3+2;
using namespace std;
int dp[maxn][maxn];
int maze[maxn][maxn];

int main(){
	int n, i, j;
	int ans, temp;
	int cont, x, y;
	while(~scanf("%d", &n) && n){
		for (i = 0; i < n; i++){
			getchar();
			for (j = 0; j < n; j++)
				scanf("%c", &maze[i][j]);
		}
		ans = 1;
		memset(dp, 0, sizeof(dp));
		for (i = 0; i < n; i++){
			for (j = 0; j < n; j++){
				if (i == 0 || j == n-1)
					dp[i][j] = 1;
				else{
					cont = 0;
					x = i-1; y = j+1;
					while(x >= 0 && y < n && maze[i][y] == maze[x][j]){
						cont++;
						x--;
						y++;
					}
					dp[i][j] = min(cont, dp[i-1][j+1]) + 1;
					ans = max(dp[i][j], ans);
				}
			}
		}
		printf("%d\n", ans);
	}	
	return 0;
} 
Published 52 original articles · won praise 2 · Views 875

Guess you like

Origin blog.csdn.net/qq_44714572/article/details/102998520