HDU 6187 Destroy Walls (thinking, maximum spanning tree)

HDU 6187 Destroy Walls (thinking, maximum spanning tree)

Destroy Walls

*Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1784 Accepted Submission(s): 692
*

Problem Description

Long times ago, there are beautiful historic walls in the city. These walls divide the city into many parts of area.

Since it was not convenient, the new king wants to destroy some of these walls, so he can arrive anywhere from his castle. We assume that his castle locates at (0.6∗2√,0.6∗3√).

There are n towers in the city, which numbered from 1 to n. The ith's location is (xi,yi). Also, there are m walls connecting the towers. Specifically, the ith wall connects the tower ui and the tower vi(including the endpoint). The cost of destroying the ith wall is wi.

Now the king asks you to help him to divide the city. Firstly, the king wants to destroy as less walls as possible, and in addition, he wants to make the cost least.

The walls only intersect at the endpoint. It is guaranteed that no walls connects the same tower and no 2 walls connects the same pair of towers. Thait is to say, the given graph formed by the walls and towers doesn't contain any multiple edges or self-loops.

Initially, you should tell the king how many walls he should destroy at least to achieve his goal, and the minimal cost under this condition.

Input

There are several test cases.

For each test case:

The first line contains 2 integer n, m.

Then next n lines describe the coordinates of the points.

Each line contains 2 integers xi,yi.

Then m lines follow, the ith line contains 3 integers ui,vi,wi

| Xi |, | yi | ≤105

3≤n≤100000,1≤m≤200000

1≤ui,vi≤n,ui≠vi,0≤wi≤10000

Output

For each test case outout one line with 2 integers sperate by a space, indicate how many walls the king should destroy at least to achieve his goal, and the minimal cost under this condition.

Sample Input

4 4
-1 -1
-1 1
1 1
1 -1
1 2 1
2 3 2
3 4 1
4 1 2

Sample Output

1 1

Source

2017ACM / ICPC Guangxi Invitational - to reproduce the game (thanks to Guangxi University)

Meaning of the questions:

What coordinate what is barbarian, the meaning of the questions a little lost.

Given a point in n, m sides without the FIG.

Q. How many sides at least delete, delete the edge of the right side sum and as little as possible, to meet the rest of the chart is still Unicom.

Ideas:

In the DAG run a maximum spanning tree, and the number of records and the edges cnt sum weights and cost spanning tree.

Also note the sum is the sum of each side and the DAG.

Then m-cnt and sum- cost is the answer and the answer 1 2.

Code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#include <iomanip>
#define ALL(x) (x).begin(), (x).end()
#define sz(a) int(a.size())
#define rep(i,x,n) for(int i=x;i<n;i++)
#define repd(i,x,n) for(int i=x;i<=n;i++)
#define pii pair<int,int>
#define pll pair<long long ,long long>
#define gbtb ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define MS0(X) memset((X), 0, sizeof((X)))
#define MSC0(X) memset((X), '\0', sizeof((X)))
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define eps 1e-6
#define gg(x) getInt(&x)
#define chu(x) cout<<"["<<#x<<" "<<(x)<<"]"<<endl
#define du3(a,b,c) scanf("%d %d %d",&(a),&(b),&(c))
#define du2(a,b) scanf("%d %d",&(a),&(b))
#define du1(a) scanf("%d",&(a));
using namespace std;
typedef long long ll;
ll gcd(ll a, ll b) {return b ? gcd(b, a % b) : a;}
ll lcm(ll a, ll b) {return a / gcd(a, b) * b;}
ll powmod(ll a, ll b, ll MOD) {a %= MOD; if (a == 0ll) {return 0ll;} ll ans = 1; while (b) {if (b & 1) {ans = ans * a % MOD;} a = a * a % MOD; b >>= 1;} return ans;}
void Pv(const vector<int> &V) {int Len = sz(V); for (int i = 0; i < Len; ++i) {printf("%d", V[i] ); if (i != Len - 1) {printf(" ");} else {printf("\n");}}}
void Pvl(const vector<ll> &V) {int Len = sz(V); for (int i = 0; i < Len; ++i) {printf("%lld", V[i] ); if (i != Len - 1) {printf(" ");} else {printf("\n");}}}

inline void getInt(int *p);
const int maxn = 1000010;
const int inf = 0x3f3f3f3f;
/*** TEMPLATE CODE * * STARTS HERE ***/
struct node {
    int f, t, w;
    node(int ff, int tt, int ww)
    {
        f = ff;
        t = tt;
        w = ww;
    }
    bool operator < (const node &b) const
    {
        return w > b.w;
    }
};
std::vector<node> v;
int x, y;
int n, m;
int ans1 = 0;
ll cost = 0ll;
ll sum = 0ll;
int fa[maxn];
void init()
{
    repd(i, 1, n) {
        fa[i] = i;
    }
}
int findpar(int x)
{
    return x == fa[x] ? x : fa[x] = findpar(fa[x]);
}
void mg(int x, int y)
{
    x = findpar(x);
    y = findpar(y);
    fa[x] = y;
}
void solve()
{
    init();
    sort(ALL(v));
    for (auto temp : v) {
        x = temp.f;
        y = temp.t;
        x = findpar(x);
        y = findpar(y);
        if (x != y) {
            mg(x, y);
            cost += temp.w;
            ans1++;
        }
    }
}
int main()
{
    //freopen("D:\\code\\text\\input.txt","r",stdin);
    //freopen("D:\\code\\text\\output.txt","w",stdout);
    gbtb;
    while (cin >> n >> m) {
        ans1 = 0ll;
        sum = 0ll;
        cost = 0ll;
        v.clear();
        repd(i, 1, n) {
            cin >> x >> y;
        }
        int z;
        repd(i, 1, m) {
            cin >> x >> y >> z;
            sum += z;
            v.push_back(node(x, y, z));
        }
        solve();
        cout << m - ans1 << " " << sum - cost << endl;
    }
    return 0;
}

inline void getInt(int *p)
{
    char ch;
    do {
        ch = getchar();
    } while (ch == ' ' || ch == '\n');
    if (ch == '-') {
        *p = -(getchar() - '0');
        while ((ch = getchar()) >= '0' && ch <= '9') {
            *p = *p * 10 - ch + '0';
        }
    } else {
        *p = ch - '0';
        while ((ch = getchar()) >= '0' && ch <= '9') {
            *p = *p * 10 + ch - '0';
        }
    }
}


Guess you like

Origin www.cnblogs.com/qieqiemin/p/11901304.html