HDU 2795 (+ thinking tree line)

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32864    Accepted Submission(s): 13090


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

 

Sample Input
3 5 5 2 4 3 3 3
 

 

Sample Output
1 2 1 3 -1

 Meaning of the questions: multiple sets of input. Give three integers, h, w, n. The number of wall height, width, and posters were representative. Next, n represents the number of lines per row a poster width (the height of a default)

Ideas: tree line on maintaining the maximum height of the wall section.

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <string>
#include <map>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
#include <vector>
//const int maxn = 1e5+5;
#define ll long long
#define inf 0x3f
#define FOR(i,a,b) for( int i = a;i <= b;++i)
#define bug cout<<"--------------"<<endl

ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
const int maxn = 200000 + 5;
using namespace std;
int h,n,w;
struct Segment
{
    int l,r;
    int sum;
    #define l(x) tree[x].l
    #define r(x) tree[x].r
    #define sum(x) tree[x].sum
}tree[maxn * 4];
void build(int q,int l,int r)
{
    l(q) = l,r(q) = r;
    if(l == r)
    {
        sum(q) = w;
        return ;
    }
    int mid = (l + r) / 2;
    build(q*2,l,mid);
    build(q*2+1,mid+1,r);
    sum(q) = max(sum(q*2),sum(q*2+1));
}
void clearr()
{
    memset( tree,0 ,sizeof(tree));
}
void ask(int q,int len)
{
    if(l(q) == r(q))
    {
        sum(q) -= len;
        //cout<<q<<endl;
        printf("%d\n",l(q) );
        return ;
    }
    if(sum(q*2) >= len) ask(q*2,len);
    else if(sum(q*2+1) >= len) ask(q*2+1,len);
    else printf("-1\n");//cout<<q<<endl;}
    sum(q) = max(sum(q*2),sum(q*2+1));
}
int main()
{

    //freopen("C:\\ACM\\input.txt","r",stdin);
    while(scanf("%d%d%d",&h,&w,&n) != EOF)
    {
        clearr();
        if(h>n)
            h=n;
        build(1,1,h);
        for(int i = 1;i <= n; ++i)
        {
            int len;
            scanf("%d",&len);
            if(sum(1) >= len )
                ask(1,len);
            else printf("-1\n");
        }

    }
}

 

Guess you like

Origin www.cnblogs.com/jrfr/p/11531877.html