HDU2056 Rectangles

Problem Description

Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input

Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output

Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input

1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00 5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output

1.00 56.25

 

code show as below:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;
void change(double &a,double &b){
        double temp=a;
        a=b;
        b=temp;
}
int main(){
    double x1,x2,x3,x4,y1,y2,y3,y4;
    double minx,miny,maxx,maxy;
    while(cin>>x1>>y1>>x2>>y2>>x3>>y3>>x4>>y4){
        if(x1>x2) change(x1,x2);
        if(x3>x4) change(x3,x4);
        if(y1>y2) change(y1,y2);
        if(y3>y4) change(y3,y4);
        minx=x1<x3?x3:x1;
        maxx=x2<x4?x2:x4;
        miny=y1<y3?y3:y1;
        maxy=y2<y4?y2:y4;
        if(minx>maxx||miny>maxy) printf("0.00\n");
        else printf("%.2f\n",(maxx-minx)*(maxy-miny));
    }
    return 0;
}

Guess you like

Origin www.cnblogs.com/jianqiao123/p/11365242.html