POJ-1001-Exponentiation (large numbers with high accuracy)

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R  nwhere R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721 
.00000005148554641076956121994511276767154838481760200726351203835429763013462401 
43992025569.928573701266488041146654993318703707511666295476720493953024 
29448126.764121021618164430206909037173276672 
90429072743629540498.107596019456651774561044010001 
1.126825030131969720661201 
Code:
import java.math.BigDecimal;
import java.util.Scanner;


public class Main {
    public static void main(String[] args) {
    Scanner s = new Scanner(System.in);
    while(s.hasNext()){
        BigDecimal b = s.nextBigDecimal();
        BigDecimal ans = BigDecimal.valueOf(1);
        int n = s.nextInt();
        while(n-- > 0)
            ans = ans.multiply(b);
        String string = ans.stripTrailingZeros().toPlainString().toString();
        if(string.startsWith("0."))
            string = string.substring(1);
        System.out.println(string);
    }
        s.close();
    }
}
In summary knowledge 
. 1, stripTrailingZeros (), returns a small number of this type of numerical values to a BigDecimal remove the tail of 0.
2, toPlainString (), return type BigDecimal string String type.
. 3, startsWith (), determining the beginning of this example matches the specified string.
. 4, the substring (), returns a new string that is a substring of this string. The substring begins at the specified character index, it has been the end of this string.

Guess you like

Origin www.cnblogs.com/Staceyacm/p/11326270.html