1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​​-city2​​ and city1​​-city3​​. Then if city1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​​-city3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

#include <the iostream> 
#include <algorithm> 
#include <cstdio>
 the using  namespace STD;
 int V [ 1001 ] [ 1001 ]; // record the communication line is not in communication by default 0 
BOOL Visit [ 1001 ]; // record is traversed 
int n-; // n-city 


void DFS ( int Node) { // recursive traversal ************************ to FIG 
    visit [node ] = to true ;
     for ( int I = . 1 ; I <= n-; I ++ ) {
         IF (Visit [I] ==to false && V [Node] [I] == . 1 ) { 
            DFS (I); 
        } 
    } 
} 
int main () 
{ 
    int m, k, A, B; // m k-way city to be checked for the route ab starting and ending points 
    CIN >> >> m >> n- K;
     for ( int I = 0 ; I <m; I ++) { // the two-dimensional array assignment represents a road 
        CIN >> A >> B; 
        V [A ] [B] = . 1 ; 
        V [B] [A] = . 1 ; 
    } 
    for ( int I = 0 ; I <K; I ++  ) {
        Fill (Visit, Visit + 1001 , to false ); // reset all cities not visit traversal 
        int TEMP = 0 ; 
        CIN >> TEMP; 
        visit [TEMP] = to true ; // was captured city, labeled to true 
        int CNT = 0 ; // record the communication component 
        for ( int J = . 1 ; J <= n-; J ++ ) {
             IF (Visit [J] == to false ) { 
                DFS (J); 
                CNT ++; // connected component +1 
            }
        } 
        COUT  << the CNT-. 1 << endl; // should be n-1 communication path between two components cnt 
    }
     return  0 ; 
}

 




Guess you like

Origin www.cnblogs.com/TBhacker/p/11299450.html