1013 Battle Over Cities (25 分)(DFS)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1​-city2​ and city1​-city3​. Then if city1​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city2​-city3​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

结尾无空行

Sample Output:

1
0
0

结尾无空行

#include<iostream>
#include<vector>
#include<cstring>
using namespace std;
//题意就是创建了一些结点 去掉一个结点后问你再创建几条边能使所有点重新联通
//其实就是求去掉结点后的联通子图的个数 输出子图个数-1 
int N,M,K,a,b,lost;
int vis[10005];
vector<int>v[10005];	//每一个结点都存放与他相邻的结点 
void dfs(int now)
{
	vis[now]=1;		//标记一下 
	int value=now;
	/*for(int value:v[value])		//遍历邻居 
	{
		if(!vis[value]&&value!=lost)
		{
			dfs(value);
		}
	}*/
	for(vector<int>::iterator it=v[value].begin();it!=v[value].end();it++)
	{
	//	cout<<"*"<<*it<<"*";
		if(!vis[*it]&&*it!=lost)
		{
			dfs(*it);
		}
	}
} 
int main()
{
	cin>>N>>M>>K;
	int count;
	for(int i=0;i<M;i++)
	{
		cin>>a>>b;
		v[a].push_back(b);	//结点a的邻居是b
		v[b].push_back(a);	//结点b的邻居是a 
	}
	for(int i=0;i<K;i++)		//进行K次判断 
	{
		count=0;
		memset(vis,0,sizeof(vis));
		cin>>lost;
		for(int i=1;i<=N;i++)
		{
			if(!vis[i]&&i!=lost)		//如果这个结点没被访问过并且不是被删除的结点就深度遍历,标记所有这个子图的结点 
			{
				count++;		//因为便遍历一次肯定是将这个子图全部标记不会再处理了
								//所以能dfs几次就代表有几个联通子图 
				dfs(i);
			}
		} 
		cout<<count-1<<endl;
	}
}

 

Guess you like

Origin blog.csdn.net/qq_52245648/article/details/119745359