Cutting Sticks (interval dp)

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,
Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work
requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For
example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.
There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price
of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6.
Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =
20, which is a better price.
Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.
Input
The input will consist of several input cases. The first line of each test case will contain a positive
number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will
contain the number n (n < 50) of cuts to be made.
The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts
have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of
cutting the given stick. Format the output as shown below.
Sample Input
100
3
25 50 75
10
4
4 5 7 8
0
Sample Output
The minimum cutting is 200.
The minimum cutting is 22.

The meaning of problems: Given a length l of the stick next to some of the cut, each cut takes the stick length, minimum cost required to complete all the required cut.

Thinking: dimensional dp, dp [i] [j ] denotes the cut section i - j takes the minimum required, then the recursion formula can be drawn: dp [i] [j] = min (dp [i] [j] , dp [i] [k] + dp [k] [j] + a [j] - a [i]) where, i <k <j
which is stored in an array of a position of the cutting point

This question has two approaches (and recursive ideas are the same)



Practice 1: memory search

#include<iostream>
#include<cstring>
using namespace std;
#define N 1005
#define inf 0x3f3f3f3f
int dp[N][N];
int a[N];
int dfs(int l,int r)
{
	if(dp[l][r]>=0)  //若此状态已经搜过
		return dp[l][r];
	if(l>=r-1)    //必须把l和r相邻的情况也特判了,否则会返回最大值
		return dp[l][r]=0;
	dp[l][r]=inf;
	for(int k=l+1;k<r;k++)
		dp[l][r]=min(dp[l][r],dfs(l,k)+dfs(k,r)+a[r]-a[l]);
	return dp[l][r];
}
int main()
{
	int l,n;
	while(~scanf("%d",&l) && l)
	{
		memset(a,0,sizeof(a));
		memset(dp,-1,sizeof(dp));
		cin>>n;
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[0]=0;a[n+1]=l;
		printf("The minimum cutting is %d.\n",dfs(0,n+1));
	}
	return 0;
}


Practice 2: non-recursive

#include<iostream>
#include<cstring>
using namespace std;
#define N 1005
#define inf 0x3f3f3f3f
int dp[N][N];
int a[N];
int main()
{
	int l,n;
	while(~scanf("%d",&l) && l)
	{
		cin>>n;
		memset(a,0,sizeof(a));
		memset(dp,0,sizeof(dp));  //注意初始化的值
		for(int i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[n+1]=l;
		for(int len=1;len<=n+1;len++)  //枚举区间长度
			for(int i=0;i+len<=n+1;i++)  //注意右边不能越界
			{
				int j=i+len;
				for(int k=i+1;k<j;k++)
				{
					if(dp[i][j]==0)   //如果为初值,直接赋值
						dp[i][j]=dp[i][k]+dp[k][j]+a[j]-a[i];
					else
						dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[j]-a[i]);
				}
			}
		printf("The minimum cutting is %d.\n",dp[0][n+1]);
	}
	return 0;
}

Guess you like

Origin blog.csdn.net/weixin_43693379/article/details/90724985