Find the Marble ZOJ - 3605 (D dp)

Alice and Bob are playing a game. This game is played with several identical pots and one marble. When the game starts, Alice puts the pots in one line and puts the marble in one of the pots. After that, Bob cannot see the inside of the pots. Then Alice makes a sequence of swappings and Bob guesses which pot the marble is in. In each of the swapping, Alice chooses two different pots and swaps their positions.

Unfortunately, Alice’s actions are very fast, so Bob can only catch k of m swappings and regard these k swappings as all actions Alice has performed. Now given the initial pot the marble is in, and the sequence of swappings, you are asked to calculate which pot Bob most possibly guesses. You can assume that Bob missed any of the swappings with equal possibility.

Input
There are several test cases in the input file. The first line of the input file contains an integer N (N ≈ 100), then N cases follow.

The first line of each test case contains 4 integers n, m, k and s(0 < s ≤ n ≤ 50, 0 ≤ k ≤ m ≤ 50), which are the number of pots, the number of swappings Alice makes, the number of swappings Bob catches and index of the initial pot the marble is in. Pots are indexed from 1 to n. Then m lines follow, each of which contains two integers ai and bi (1 ≤ ai, bi ≤ n), telling the two pots Alice swaps in the i-th swapping.

Outout
For each test case, output the pot that Bob most possibly guesses. If there is a tie, output the smallest one.

Sample Input
3
3 1 1 1
1 2
3 1 0 1
1 2
3 3 2 2
2 3
3 2
1 2
Sample Output
2
1
3

The meaning of problems: there are n cup, there are only a stone at the beginning of m times twenty-two exchange operation, you can only see the times in which k, k time of asking after the most likely guess which cup

Thinking: dp [i] [j] [x] denotes the i-th former exchange saw j times, the last position of the stone in the program number x of
different i, for every j (j is smaller than i must meet, and the ratio small k), we have seen the exchange and the exchange did not see the two cases
did not see: dp [i] [j] [x] + = dp [i-1] [j] [x]
seen:
1. If this round (round i) for operation independently of the cup, i.e. x! = a [i] && x! = where b [i] of. Then it is also the end of the last round when x. DP [I] [J] [X] + DP = [. 1-I] [J-. 1] [X]
2. if x == a [i], it is from the end on a b [i] Transfer , i.e. dp [i] [j] [ x] + = dp [i-1] [j-1] [b [i]]
if x == b [i], from one end to the a [i] transfer, i.e. dp [i] [j] [ x] + = dp [i-1] [j-1] [a [i]]

#include<bits/stdc++.h>
using namespace std;
#define N 60
typedef long long ll;
ll dp[N][N][N];    //注意结果很大,要用long long存,否则会wa
int a[N];
int b[N];
int main()
{
	int n,m,k,s,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d%d",&n,&m,&k,&s);
		memset(dp,0,sizeof(dp));
		dp[0][0][s]=1;
		for(int i=1;i<=m;i++)
			scanf("%d%d",&a[i],&b[i]);
		for(int i=1;i<=m;i++)
		{
			dp[i][0][s]=1;
			for(int j=1;j<=min(i,k);j++)
			{	
				for(int len=1;len<=n;len++)
				{
					dp[i][j][len]+=dp[i-1][j][len];   //没看见,直接继承上一轮的结果
					if(len==a[i])       //看到了,分类讨论
						dp[i][j][a[i]]+=dp[i-1][j-1][b[i]];
					else if(len==b[i])
						dp[i][j][b[i]]+=dp[i-1][j-1][a[i]];
					else
						dp[i][j][len]+=dp[i-1][j-1][len];
				}
			}
		}
		ll ans=dp[m][k][1],u=1;
		for(int i=2;i<=n;i++)
			if(dp[m][k][i]>ans)
			{
				ans=dp[m][k][i];
				u=i;
			}
		cout<<u<<endl;
	}
	return 0;
}

Guess you like

Origin blog.csdn.net/weixin_43693379/article/details/91129800
ZOJ
ZOJ