【UVA - 10474 】Where is the Marble?(排序)

Where is the Marble?

Descriptions:

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Rajuto find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

  • `x found at y', if the first marble with number x was found at position y. Positions are numbered 1, 2,..., N.

  • `x not found', if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

Topic links:

https://vjudge.net/problem/UVA-10474

 

N subject to the effect that the existing marble, wrote a non-negative integer on each marble. First, the respective number of small to large order, then Q answer questions. Each question asks whether there is a marble that says some integer x, if so, on which even answer that says x marble. Marble is sorted from left to right No. 1 ~ N.

With two simple functions to sort and lower_bound

AC Code

#include <iostream>
#include <cstdio>
#include <fstream>
#include <algorithm>
#include <cmath>
#include <deque>
#include <vector>
#include <queue>
#include <string>
#include <cstring>
#include <map>
#include <stack>
#include <set>
#include <sstream>
#define mod 1000000007
#define ll long long
#define INF 0x3f3f3f3f
#define ME0(x) memset(x,0,sizeof(x))
using namespace std;
int N,Q;
int a[10005];
int sum=0;
int main()
{
    while(cin>>N>>Q,N+Q)
    {
        sum++;
        ME0(a);
        for(int i=0; i<N; i++)
            cin>>a[i];
        sort(a,a+N);//排序
        printf("CASE# %d:\n",sum);
        while(Q - ) 
        { 
            int NUM; 
            CIN >> NUM;
             // lower_bound (start address, end address, to find the value) 
             // address: front opening closed. Returns a first value greater than or equal to a position that appears
             // If the value is greater than all the elements in the array, it returns the end address. 
            int T = lower_bound (A, A + N, NUM) - A;
             IF (A [T] == NUM) 
                the printf ( " % D found AT% D \ n- " , NUM, T + . 1 );
             the else 
                the printf ( " % Not found D \ n- " , NUM); 
        } 
    } 

}

 

Guess you like

Origin www.cnblogs.com/sky-stars/p/10988482.html