#POJ 2239 Selecting Courses (Hungary maximum matching algorithm / bipartite graph)

Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more as possible. Of course there should be no conflict among the courses he selects.

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks, a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him?

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <= 7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.

Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.

Sample Input

5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output

4

 Subject to the effect: given the number of courses and class time is given for each lesson can be selected (the first week X Y class), find the maximum number of courses to choose from.

Thinking: if Hungary algorithm to understand the words of this question and the question is no different template. I call this the algorithm as a "connection" issues template to the chart are generally one-dimensional even one-dimensional, but even this question is a one-dimensional two-dimensional, one-dimensional: subscript course, that is equivalent to math class, ah, ah language classes so that only one element. Two-dimensional: day of the week and the first few classes, which consists of two parts a. So we just change the algorithm on the template a little bit, is that the answer to this question! Hungarian algorithm how to achieve specific, online bigwigs draw a map than a clear Ha, I will not explain. Sentence: If the cable can be connected between the two, then the even, if not, skip, if it has been connected to the other points, can try to change the point a line is connected, and the cloth, It is a recursive process (in fact, more than a word ..)

AC Code:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn = 3e2 + 5;

int p[maxn][15][15], net[15][15], n, t;
bool vis[15][15];
bool find_(int x) {
    for (int i = 1; i <= 7; i++) {
        for (int j = 1; j <= 12; j++) {
            if (!vis[i][j] && p[x][i][j]) {
                vis[i][j] = 1;
                if (!net[i][j] || find_(net[i][j])) {
                    net[i][j] = x;
                    return true;
                }
            }
        }
    }
    return false;
}

int main()
{
    while (cin >> n) {
        memset(p, 0, sizeof(p));
        memset(net, 0, sizeof(net));
        for (int i = 1; i <= n; i++) {
            cin >>t;
            while (t--) {
                int ai, bi;
                cin >> ai >> bi;
                p[i][ai][bi] = 1;
            }
        }
        int ans = 0;
        for (int i = 1; i <= n; i++) {
            memset(vis, 0, sizeof(vis));
            if (find_(i)) ans++;
        }
        cout << ans << endl;
    }
    return 0;
}

 

Guess you like

Origin blog.csdn.net/weixin_43851525/article/details/91373918