[Graph Theory][Bipartite Graph Maximum Matching]Courses

Problem Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

. every student in the committee represents a different course (a student can represent a course if he/she visits that course)

. each course has a representative in the committee

Your program should read sets of data from a text file. The first line of the input file contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
......
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses . from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you'll find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.

There are no blank lines between consecutive sets of data. Input data are correct.

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

An example of program input and output:
 

 

Sample Input
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
 

 

Sample Output
YES NO
 
 
Idea: The bare question with the maximum matching of the bipartite graph, and all courses are successfully matched, output YES, otherwise output NO.
AC code:
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int p,n;
int Map[350][350];
int used[350];
int vis[350];

bool match(int x){
  for(int i=1;i<=n;i++){
    if(!vis[i]&&Map[x][i]){
        vis[i]=1;
        if(!used[i]||match(used[i])){
            used[i]=x;
            return true;
        }
    }
  }
  return false;
}

intmain ()
{
    int t;
    scanf("%d",&t);
    while(t--){
        memset(Map,0,sizeof(Map));
        scanf("%d%d",&p,&n);
        for(int i=1;i<=p;i++){
            int num;
            scanf("%d",&num);
            for(int j=1;j<=num;j++){
                int x;
                scanf("%d",&x);
                Map[i][x]=1;
            }
        }
        int ans= 0 ;
        memset(used,0,sizeof(used));
        for(int i=1;i<=p;i++){
            memset(vis,0,sizeof(vis));
            if(match(i)) ans++;
        }
        if(ans!=p) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}
 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325939781&siteId=291194637