Poj1459 Power Network to promote pre-flow

Poj1459 Power Network to promote pre-flow

Problem Description:

A power network consists of nodes (power stations, consumers and
dispatchers) connected by power transport lines. A node u may be
supplied with an amount s(u) >= 0 of power, may produce an amount 0
<= p(u) <= p
max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c
max(u)) of power, and may deliver an amount
d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0
for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any
dispatcher. There is at most one power transport line (u,v) from a node u
to a node v in the net; it transports an amount 0 <= l(u,v) <= l
max(u,v) of power delivered by u to v. Let Con=Σ
uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.
img

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p
max(u)=y. The label x/y of consumer u shows that c(u)=x and c
max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l
max(u,v)=y. The power consumed is Con=6. Notice that
there are other possible states of the network but the value of Con
cannot exceed 6.

Input

​ There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

​ For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample output

15

6

analysis:

This problem may employ the maximum flow network model of the network to solve the maximum flow requires a source and sink, and in the original plant, station schedule and consumers can not as a source node and sink, so the original basis Add a source and a sink vertex number to n + 1 and n + 2.

After the introduction of the source and sink for each plant, the capacity of a lead from the source point pmax arc; from each consumer, cited an arc cmax capacity to sink; for the title of triplets ( u, v) z. even from a vertex u z capacity arc to the vertex v. So that each consumer's actual consumption amount of current flowing into the sink, the maximum amount of current source is provided for each of the power plant and pmax.

The maximum flow can be solved directly below, the method used here is pre-flow propulsion.

#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
const int maxn = 110;
const int maxf = 0x7fffffff;
int n,np,nc,m;
int resi[maxn][maxn];
deque<int> act;
int h[maxn];
int ef[maxn];
int s,t,V;
void push_relabel() {
    int sum = 0;
    int u,v,p;
    for(int i = 1;i <= V;i++) h[i] = 0;
    h[s] = V;
    memset(ef,0,sizeof(ef));
    ef[s] = maxf;ef[t] = -maxf;
    act.push_front(s);
    while(!act.empty()) {
        u = act.back();
        act.pop_back();
        for(int i = 1;i <= V;i++) {
            v = i;
            if(resi[u][v] < ef[u]) p = resi[u][v];
            else p = ef[u];
            if(p > 0 && (u == s || h[u] == h[v] + 1)) {
                resi[u][v]-=p;resi[v][u]+=p;
                if(v == t) sum+=p;
                ef[u]-=p;ef[v]+=p;
                if(v != s && v != t) act.push_front(v);
            }
        }
        if(u != s && u != t && ef[u] > 0) {
            h[u]++;
            act.push_front(u);
        }
    } 
    printf("%d\n",sum);
}
int main() {
    int u,v,val;
    while(scanf("%d%d%d%d",&n,&np,&nc,&m) != EOF) {
        s = n + 1;t = n + 2;V =  n+2;
        memset(resi,0,sizeof(resi));
        for(int i = 0;i < m;i++) {
            while(getchar() != '(');
            scanf("%d,%d)%d",&u,&v,&val);
            resi[u+1][v+1] = val;
        }
        for(int i = 0;i < np;i++) {
            while(getchar() != '(');
            scanf("%d)%d",&u,&val);
            resi[s][u+1] = val;
        }    
        for(int i = 0;i < nc;i++) {
            while(getchar() != '(');
            scanf("%d)%d",&u,&val);
            resi[u+1][t] = val;
        }
        push_relabel();
    }
    return 0;
}

Guess you like

Origin www.cnblogs.com/pot-a-to/p/10959986.html