isis basic encyclopedia study case

Insert image description here

R1 configuration:

isis 1
is-level level-2
//Only level-2 level is enabled in this area
cost-style wide
//The default is narrow measurement, the cost can only be up to 63, and cannot be tagged. The tlv of wide width does not match narrow. , routes cannot be calculated for each other, and both sides must change.
network-entity 49.0001.0000.0000.0001.00
is-name r1
//After repeating the command, it will be more intuitive to view lsdb. But when checking the specific details, you need to bring is-name, 侞dis isis lsdb is-name r2.00-00 verbose

interface GigabitEthernet0/0/0
ip address 10.0.12.1 255.255.255.0
isis enable 1
isis circuit-type p2p
//Change to pep link
isis ppp-negotiation 3-way only
//Force to use 3-way handshake, the default is 2-way handshake reliable.

interface GigabitEthernet0/0/1
ip address 10.0.13.1 255.255.255.0
isis enable 1

interface LoopBack0
ip address 1.1.1.1 255.255.255.255
isis enable 1

r2 configuration:

isis 1
is-level level-2
cost-style wide
network-entity 49.0001.0000.0000.0002.00
is-name r2

interface GigabitEthernet0/0/0
ip address 10.0.12.2 255.255.255.0
isis enable 1
isis circuit-type p2p
isis ppp-negotiation 3-way only

interface GigabitEthernet0/0/1
ip address 10.0.24.2 255.255.255.0
isis enable 1

interface GigabitEthernet0/0/2
ip address 10.0.26.2 255.255.255.0
isis enable 1

interface LoopBack0
ip address 2.2.2.2 255.255.255.255
isis enable 1

R3 configuration:

isis 1
cost-style wide
network-entity 49.0002.0000.0000.0003.00
is-name r3
import-route isis level-2 into level-1
//isis route penetration, penetrate the detailed routes in level-2 into level-1

interface Serial1/0/0
link-protocol ppp
ip address 10.0.35.3 255.255.255.0
isis enable 1
isis circuit-level level-1
//Since the device uses the default level-1-2, this interface will issue an error after enabling isis enable. There are two types of packages, level-1 and level-2, but package 2 is not used, only package 1 is used, so for the sake of performance, package 2 is not sent.
isis cost 100 level-1
//R5 has two ways to go, R3 and R4, so the cost of the interfaces to R3 and R5 is changed, and the others go to R4.
isis ppp-negotiation 3-way only

interface Serial1/0/1
link-protocol ppp

interface GigabitEthernet0/0/0
ip address 10.0.13.3 255.255.255.0
isis enable 1
isis circuit-level level-2
//This interface only connects level-2 and not level-1 packets, so filter them out to improve performance.

interface GigabitEthernet0/0/1
ip address 10.0.34.3 255.255.255.0
isis enable 1
//R3 and R4 interconnection use the default level-1-2 to connect both levels. First, you can experiment with the backup interconnection in the upper backbone area. Second, It can solve the sub-optimal path and prevent the data packets from R3 to R4 from going around R5.

interface LoopBack0
ip address 3.3.3.3 255.255.255.255
isis enable 1

R4 configuration:

isis 1
cost-style wide
network-entity 49.0002.0000.0000.0004.00
is-name r4
import-route isis level-2 into level-1
//Similarly do route penetration

interface GigabitEthernet0/0/0
ip address 10.0.34.4 255.255.255.0
isis enable 1
//R3 and R4 interconnection use the default level-1-2 to connect at both levels. One is to experiment with the backup interconnection in the upper backbone area, and the other is It can solve the sub-optimal path and prevent the data packets from R3 to R4 from going around R5.

interface GigabitEthernet0/0/1
ip address 10.0.24.4 255.255.255.0
isis enable 1
isis circuit-level level-2
//Just send level-2 packets

interface GigabitEthernet0/0/2
ip address 10.0.45.4 255.255.255.0
isis enable 1
isis circuit-level level-1
//Only send level-1 packets

interface LoopBack0
ip address 4.4.4.4 255.255.255.255
isis enable 1

R5 configuration:

isis 1
is-level level-1
//This device only needs level-1
cost-style wide
network-entity 49.0002.0000.0000.0005.00
is-name r5

interface Serial1/0/0
link-protocol ppp
ip address 10.0.35.5 255.255.255.0
isis enable 1
isis cost 100 level-1
//Change the cost of the interface with R3 to 100, which is used to go up R4.
isis ppp-negotiation 3-way only

interface GigabitEthernet0/0/1
ip address 10.0.45.5 255.255.255.0
isis enable 1

interface LoopBack0
ip address 5.5.5.5 255.255.255.255
isis enable 1

R6 configuration:

isis 1
cost-style wide
network-entity 49.0003.0000.0000.0006.00
is-name r6

interface GigabitEthernet0/0/0
ip address 10.0.26.6 255.255.255.0
isis enable 1
isis circuit-level level-2
//The uplink port only needs to enable level-2 to improve performance

interface GigabitEthernet0/0/1
ip address 10.0.67.6 255.255.255.0
isis enable 1
isis circuit-level level-1
//The downlink port only needs to enable level-1 to improve performance

interface LoopBack0
ip address 6.6.6.6 255.255.255.255
isis enable 1

R7 configuration:

isis 1
is-level level-1
cost-style wide
network-entity 49.0003.0000.0000.0007.00
is-name r7
import-route direct level-1
//The level-1 device has the same principle as the total-nssa area and can import external routes
import-route static level-1
//Import static routing

interface GigabitEthernet0/0/0
ip address 10.0.67.7 255.255.255.0
isis enable 1

interface GigabitEthernet0/0/1
ip address 10.0.0.110 255.255.255.0

interface LoopBack0
ip address 7.7.7.7 255.255.255.255
isis enable 1

ip route-static 70.0.0.0 255.255.255.0 NULL0
//Used to test the import routing experiment

Check which ports of this device are connected to level-1 devices:

Insert image description here

Pseudo node view:

Insert image description here

Distinguish between p2p and broadcast links, view on R1:

Insert image description here

See what is learned through penetration in R5:

Insert image description here

Summary of important parts:

Isis only has the concept of dr, not called dr, but called dis. The default comparison weight is the same. If it is the same, the larger mac address is dis. The isis weight range is 0-127, and the default is 64

Routes that can be learned through penetration will be calculated again by level-1-2, so they will not be passed to level-2 to cause loops, which is the same as ospf.

In isis, broadcast links will establish adjacencies with each other, but in ospf, drothers will not establish adjacencies, but will only establish neighbors to 2-way.

There are only two network types in isis, p2p and broadcast, and the mtU sizes on both sides must be consistent. If they are inconsistent, the isis hello message cannot be received.

View the dis isis name-table corresponding to all custom system commands connected to this device

Guess you like

Origin blog.csdn.net/ydaxia110/article/details/134620244