Network test using Huawei eNSP⑴-Communication between network devices through Vlan

  When I learned about networking in 2019, I started learning from Cisco products. At that time, I came into contact with Cisco’s 6506, 4506, 3750, 3550, and 2950. Because there were many network devices, I basically operated them directly on the redundant devices, and then used them after mastering them. Go to the field device to operate. At that time, I used Cisco's simulator CISCO Packet Tracer, which has the following interface:

  Now it feels very earthy, but when I used it at the time, I thought it was okay, and it still felt quite magical. I have never used simulators when studying H3C and Huawei products. I have also installed it, but it may be different from the use of Cisco. If it feels awkward, it is useless. It is operated on a real machine and the experience is better.

  Seeing that others are using it very well, I downloaded eNSP today. I still want to use it. It must be good that so many people are using it.

  The installation is very simple, provided that wireshark and VirtualBox need to be installed correctly.

  Today, eNSP is used for networking experiments, which uses vlan to communicate between network devices. eNSP is still very convenient, but there are not many device models, and additional downloads of other devices are required.

  Experimental picture:

  PC1: in Vlan10, IP address: 192.168.1.2, gateway address: 192.168.1.1, subnet mask: 255.255.255.224

  PC4: in Vlan20, IP address: 192.168.1.34, gateway address: 192.168.1.33, subnet mask: 255.255.255.224

  PC2: in Vlan30, IP address: 172.16.1.2, gateway address: 172.16.1.1, subnet mask: 255.255.255.224

  PC5: in Vlan40, IP address: 172.16.1.34, gateway address: 172.16.1.33, subnet mask: 255.255.255.224

  Now it is required that PC1, PC2, PC4, and PC5 can access each other.

  First, ensure the interconnection between network devices and use Vlan9 to allow all network devices to communicate with each other. Of course, they can also be under different vlans. The second step is to specify the route. Static routing is used here.

  Router R5:

<HUAWEI>sys
[HUAWEI]undo info-center enable
[HUAWEI]sysname R5
[R5]vlan 9
[R5-vlan9]quit
[R5]interface Vlanif 9
[R5-Vlanif9]ip address 192.168.10.4 255.255.255.0
[R5-Vlanif9]quit
[R5]interface Ethernet 0/0/0
[R5-Ethernet0/0/0]portswitch
[R5-Ethernet0/0/0]port link-type access
[R5-Ethernet0/0/0]port default vlan 9
[R5-Ethernet0/0/0]quit
[R5]interface Ethernet 0/0/1
[R5-Ethernet0/0/1]portswitch
[R5-Ethernet0/0/1]port link-type access
[R5-Ethernet0/0/1]port default vlan 9
[R5-Ethernet0/0/1]quit
[R5]ip route-static 172.16.1.0 255.255.255.0 192.168.10.5
[R5]ip route-static 192.168.1.0 255.255.255.0 192.168.10.3

  Router R6:

<HUAWEI>sys
[HUAWEI]undo info-center enable
[HUAWEI]sysname R6
[R6]vlan 9
[R6-vlan9]quit
[R6]interface Vlanif 9
[R6-Vlanif9]ip address 192.168.10.5 255.255.255.0
[R6-Vlanif9]quit
[R6]interface Ethernet 0/0/0
[R6-Ethernet0/0/0]portswitch
[R6-Ethernet0/0/0]port link-type access
[R6-Ethernet0/0/0]port default vlan 9
[R6-Ethernet0/0/1]quit
[R6]interface Ethernet 0/0/1
[R6-Ethernet0/0/1]portswitch
[R6-Ethernet0/0/1]port link-type access
[R6-Ethernet0/0/1]port default vlan 9
[R6-Ethernet0/0/1]quit
[R6]ip route-static 172.16.1.0 255.255.255.0 192.168.10.6
[R6]ip route-static 192.168.1.0 255.255.255.0 192.168.10.4

  Router R7:

<HUAWEI>sys
[HUAWEI]undo info-center enable
[HUAWEI]sysname R7
[R7]vlan 9
[R7-vlan9]quit
[R7]interface Vlanif 9
[R7-Vlanif9]ip address 192.168.10.5 255.255.255.0
[R7-Vlanif9]quit
[R7]interface Ethernet 0/0/0
[R7-Ethernet0/0/0]portswitch
[R7-Ethernet0/0/0]port link-type access
[R7-Ethernet0/0/0]port default vlan 9
[R7-Ethernet0/0/0]quit
[R7]interface Ethernet 0/0/1
[R7-Ethernet0/0/1]portswitch
[R7-Ethernet0/0/1]port link-type access
[R7-Ethernet0/0/1]port default vlan 9
[R7-Ethernet0/0/1]quit
[R7]ip route-static 172.16.1.0 255.255.255.0 192.168.10.7
[R7]ip route-static 192.168.1.0 255.255.255.0 192.168.10.5

  Switch HUAWEI S7706-A:

<HUAWEI>sys
[HUAWEI]sysname HUAWEI S7706-A
[HUAWEI S7706-A]vlan 9
[HUAWEI S7706-A-vlan9]quit
[HUAWEI S7706-A]interface Vlanif 9
[HUAWEI S7706-Vlanif9]ip address 192.168.10.3 255.255.255.0
[HUAWEI S7706-Vlanif9]quit
[HUAWEI S7706-A]vlan 10
[HUAWEI S7706-A-vlan10]quit
[HUAWEI S7706-A]interface Vlanif 10
[HUAWEI S7706-Vlanif10]ip address 192.168.1.1 255.255.255.224
[HUAWEI S7706-Vlanif10]quit
[HUAWEI S7706-A]interface Vlanif 20
[HUAWEI S7706-Vlanif20]ip address 192.168.1.33 255.255.255.224
[HUAWEI S7706-Vlanif20]quit
[HUAWEI S7706-B]interface GigabitEthernet 0/0/2
[HUAWEI S7706-B-GigabitEthernet0/0/2]port link-type access
[HUAWEI S7706-B-GigabitEthernet0/0/2]port default vlan 10
[HUAWEI S7706-B-GigabitEthernet0/0/2]quit
[HUAWEI S7706-B]interface GigabitEthernet 0/0/3
[HUAWEI S7706-B-GigabitEthernet0/0/3]port link-type access
[HUAWEI S7706-B-GigabitEthernet0/0/3]port default vlan 20
[HUAWEI S7706-B-GigabitEthernet0/0/3]quit
[HUAWEI S7706-A]ip route-static 172.16.1.0 255.255.255.0 192.168.10.4

  Switch HUAWEIS7706-B:

<HUAWEI>sys
[HUAWEI]sysname HUAWEI S7706-B
[HUAWEI S7706-B]vlan 9
[HUAWEI S7706-B-vlan9]quit
[HUAWEI S7706-B]interface Vlanif 9
[HUAWEI S7706-B-Vlanif9]ip address 192.168.10.7 255.255.255.0
[HUAWEI S7706-B-Vlanif9]quit
[HUAWEI S7706-B]vlan 30
[HUAWEI S7706-B-vlan30]quit
[HUAWEI S7706-B]interface Vlanif 30
[HUAWEI S7706-B-Vlanif30]ip address 172.16.1.1 255.255.255.224
[HUAWEI S7706-B-Vlanif30]quit
[HUAWEI S7706-B]interface Vlanif 40
[HUAWEI S7706-B-Vlanif40]ip address 172.16.1.33 255.255.255.224
[HUAWEI S7706-B-Vlanif40]quit
[HUAWEI S7706-B]interface GigabitEthernet 0/0/2
[HUAWEI S7706-B-GigabitEthernet0/0/2]port link-type access
[HUAWEI S7706-B-GigabitEthernet0/0/2]port default vlan 30
[HUAWEI S7706-B-GigabitEthernet0/0/2]quit
[HUAWEI S7706-B]interface GigabitEthernet 0/0/3
[HUAWEI S7706-B-GigabitEthernet0/0/3]port link-type access
[HUAWEI S7706-B-GigabitEthernet0/0/3]port default vlan 40
[HUAWEI S7706-B-GigabitEthernet0/0/3]quit
[HUAWEI S7706-B]ip route-static 192.168.1.0 255.255.255.0 192.168.10.6

  After the above configuration, four PC machines can communicate with each other.

  Basic settings of PC1:

  ping test:

Guess you like

Origin blog.csdn.net/dawn0718/article/details/133251208