Ruijie RSR Series Routers_IP Routing Protocol_RIP

Table of contents

01 RIP basic configuration

02 Basic configuration under VRF

03 Redistribution

04 Summary


 

01 RIP basic configuration

Features:

RIP (Routing Information Protocol) routing protocol is a relatively old routing protocol that has been widely used in small and same-media networks. RIP adopts the distance vector algorithm and is a distance vector protocol. RIPv1 is defined in RFC 1058, and RIPv2 is defined in RFC 2453. Ruijie RGOS software supports both versions. RIP uses UDP packets to exchange routing information, and the UDP port number is 520. Generally, RIPv1 packets are broadcast packets; RIPv2 packets are multicast packets, and the multicast address is 224.0.0.9. RIP sends an update packet every 30 seconds. If the device does not receive a routing update message from the peer after 180 seconds, it will mark all the routing information from this device as unreachable. Removed from the routing table. 

Application scenario:

The network scale of the enterprise is relatively small, with less than 10 routers. In order to realize that the entire network can communicate with each other and share data, the RIP protocol can be enabled on all routers in the entire network.

1. Networking requirements

The routers in the whole network run the rip protocol, so that the routes in the whole network are reachable.

      

2. Network topology

 

3. Configuration points

1. The basic ip address configuration of the whole network

2. Enable rip on the entire network routing, and notify the corresponding interface to the rip process

4. Configuration steps

1. The basic ip address configuration of the whole network

Ruijie(config)#hostname R1

R1(config)#interface gigabitEthernet 0/0

R1(config-GigabitEthernet 0/0)#ip address 192.168.1.1 255.255.255.0

R1(config-GigabitEthernet 0/0)#exit

R1(config)#interface gigabitEthernet 0/1

R1(config-GigabitEthernet 0/1)#ip address 10.1.1.1 255.255.255.0

R1(config-GigabitEthernet 0/1)#exit

Ruijie(config)#hostname R2

R2(config)#interface fastEthernet 0/0

R2(config-if-FastEthernet 0/0)#ip address 192.168.1.2 255.255.255.0

R2(config-if-FastEthernet 0/0)#exit

R2(config)#interface fastEthernet 0/1

R2(config-if-FastEthernet 0/1)#ip address 192.168.2.1 255.255.255.0

R2(config-if-FastEthernet 0/1)#exit

Ruijie(config)#hostname R3

R3(config)#interface fastEthernet 0/0

R3(config-if-FastEthernet 0/0)#ip address 10.4.1.1 255.255.255.0

R3(config-if-FastEthernet 0/0)#exit

R3(config)#interface fastEthernet 0/1

R3(config-if-FastEthernet 0/1)#ip address 192.168.2.2 255.255.255.0

R3(config-if-FastEthernet 0/1)#exit

2. Enable rip on the entire network routing, and notify the corresponding interface to the rip process

Notice:

1) There are two versions of rip, version 1 and version 2. Version 2 uses multicast update instead of broadcast update and carries routing mask information. It is recommended to use rip version 2.

2) When rip notifies the network through the command network, it can only notify the main network . Even if network writes the subnet address, it will also notify the main network. All interfaces belonging to the main network will be notified into the rip process.

3) By default, rip will automatically summarize at the border of the main network . If there is a discontinuous network, it will cause abnormal routing learning. It is recommended that after enabling the rip protocol, turn off automatic summary and use manual summary.

R1(config)#router rip

R1(config-router)#version 2 //Enable rip version 2

R1(config-router)#no auto-summary       //Turn off automatic summary

R1(config-router)#network 192.168.1.0     //Notify the 192.168.1.0 network segment into the rip process

R1(config-router)#network 10.0.0.0

R1(config-router)#exit

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 192.168.1.0

R2(config-router)#network 192.168.2.0

R2(config-router)#exit

R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#no auto-summary

R3(config-router)#network 192.168.2.0

R3(config-router)#network 10.0.0.0

R3(config-router)#exit

5. Configuration Verification

Check the routes of the routers in the entire network. If each router can learn the routes of the entire network, the rip configuration is correct.

 


02 Basic configuration under VRF

Features:

RIP (Routing Information Protocol) routing protocol is a relatively old routing protocol that has been widely used in small and same-media networks. RIP adopts the distance vector algorithm and is a distance vector protocol. RIPv1 is defined in RFC 1058, and RIPv2 is defined in RFC 2453. Ruijie RGOS software supports both versions. RIP uses UDP packets to exchange routing information, and the UDP port number is 520. Generally, RIPv1 packets are broadcast packets; RIPv2 packets are multicast packets, and the multicast address is 224.0.0.9. RIP sends an update packet every 30 seconds. If the device does not receive a routing update message from the peer after 180 seconds, it will mark all the routing information from this device as unreachable. Removed from the routing table. 

1. Networking requirements

The F0/0 and F0/1 interfaces of router R1 are under vrf abc, router R2 is an ordinary global router, and the routers in the entire network run the rip protocol to make the routes of the entire network reachable.

      

2. Network topology

 

3. Configuration points

1. Configure vrf abc on R1

2. Basic ip address configuration

3. Assign the corresponding interface to vrf on R1

4. Enable rip on the entire network routing, and notify the corresponding interface to the rip process

4. Configuration steps

1. Configure vrf abc on R1

Notice:

The vrf is effective locally. When the vrf is enabled on the local end, the interfaces under the same vrf on the local router can communicate with each other, and the interfaces of different vrfs are logically isolated. It has nothing to do with whether the peer router has vrf enabled.

Ruijie(config)#hostname R1

R1(config)#ip vrf abc     //Enable vrf abc on the router

R1(config-vrf)#exit

2. Basic ip address configuration

R1(config)#interface fastEthernet 0/2

R1(config-if-FastEthernet 0/2)#ip address 192.168.1.1 255.255.255.0

R1(config-if-FastEthernet 0/2)#exit

R1(config)#interface fastEthernet 0/0

R1(config-if-FastEthernet 0/0)#ip address 10.1.1.1 255.255.255.0

R1(config-if-FastEthernet 0/0)#exit

Ruijie(config)#hostname R2

R2(config)#interface fastEthernet 0/0

R2(config-if-FastEthernet 0/0)#ip address 192.168.1.2 255.255.255.0

R2(config-if-FastEthernet 0/0)#exit

R2(config)#interface fastEthernet 0/1

R2(config-if-FastEthernet 0/1)#ip address 10.2.1.1 255.255.255.0

R2(config-if-FastEthernet 0/1)#exit

3. Assign the corresponding interface to vrf on R1

Notice:

When adding an interface to vrf, if the interface has an ip address configured, the ip address will be removed , and the ip address of the interface needs to be reconfigured.

R1(config)#interface fastEthernet 0/2

R1(config-if-FastEthernet 0/2)#ip vrf forwarding abc

% Interface FastEthernet 0/2 IP address 192.168.1.1 removed due to enabling VRF abc

R1(config-if-FastEthernet 0/2)#ip address 192.168.1.1 255.255.255.0       //Reconfigure the ip address of the F0/2 interface

R1(config-if-FastEthernet 0/2)#exit

R1(config)#interface fastEthernet 0/0

R1(config-if-FastEthernet 0/0)#ip vrf forwarding abc

% Interface FastEthernet 0/0 IP address 10.1.1.1 removed due to enabling VRF abc

R1(config-if-FastEthernet 0/0)#ip address 10.1.1.1 255.255.255.0

R1(config-if-FastEthernet 0/0)#exit

4. Enable rip on the entire network routing, and notify the corresponding interface to the rip process

Notice:

The RIP configuration under vrf is just that the corresponding configuration needs to be address-family ipv4 vrf under the corresponding vrf . The precautions for configuring rip under vrf are the same as configuring ordinary rip. Please refer to the relevant chapters of rip basic configuration.

R1(config)#router rip

R1(config-router)#address-family ipv4 vrf abc      //Enable the rip protocol under vrf abc

R1(config-router-af)#version 2     //Enable rip version 2

R1(config-router-af)#no auto-summary    //Turn off automatic summary

R1(config-router-af)#network 192.168.1.0   //Notify the 192.168.1.0 network segment into the rip process

R1(config-router-of)#network 10.0.0.0

R1(config-router-af)#exit

R1(config-router)#exit

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 192.168.1.0

R2(config-router)#network 10.0.0.0

R2(config-router)#exit

5. Configuration Verification

Check the routing table under the VRF corresponding to R1 and the global routing tables of other routers. If each router can learn the routes of the entire network, the rip configuration under the VRF is correct.

R1#show ip route vrf abc

Routing Table: abc

Codes:  C - connected, S - static, R - RIP, B - BGP

        O - OSPF, IA - OSPF inter area

        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

        E1 - OSPF external type 1, E2 - OSPF external type 2

        i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

        ia - IS-IS inter area, * - candidate default

Gateway of last resort is no set

C    10.1.1.0/24 is directly connected, FastEthernet 0/0

C    10.1.1.1/32 is local host.

R 10.2.1.0/24 [120/1] via 192.168.1.2, 00:02:53, FastEthernet 0/2

C    192.168.1.0/24 is directly connected, FastEthernet 0/2

C    192.168.1.1/32 is local host.


03 Redistribution

Features:

The route redistribution function can import routes learned from other routing protocols into the rip domain.

Application scenario:

A variety of routing protocols are enabled in the enterprise network. In order to enable the entire network to communicate with each other and share data, it is necessary to introduce the routes of other routing protocols into the RIP protocol.

1. Networking requirements

In addition to the rip protocol running on the entire network, there are other routing protocols, and the routes learned by other routing protocols need to be redistributed into rip.            

      

2. Network topology

 

3. Configuration points

1. The ip address and basic rip configuration of the router in the whole network

2. Configure a static route to network 10.1.2.0/24 on R1

3. Redistribute static routes into rip

4. Configuration steps

1. The ip address and basic rip configuration of the router in the whole network

Configuration reference "RIP basic configuration" chapter (typical configuration--->IP routing--->RIP--->basic configuration)

2. Configure a static route to network 10.1.2.0/24 on R1

R1(config)#ip route 10.1.2.0 255.255.255.0 192.168.11.2

3. Redistribute static routes into rip

Notice:

1) rip redistributes the routing commands learned by other routing protocols as follows:

R1(config)#router rip

R1(config-router)#redistribute ?

  bgp        Border Gateway Protocol (BGP)

  connected  Connected

  ospf       Open Shortest Path First (OSPF)

  static     Static routes

2) The external route imported by rip is the effective route of this router, which must be the route that can be seen by show ip route on this router

3) The external route imported by rip must specify a metric , the default metric is infinite, and the imported external route is invalid

The following is an example of importing static routes by rip, and the same is true for other routing protocols.

R1(config)#router rip

R1(config-router)#redistribute static metric 1      //Redistribute the static route into rip, and configure the metric as 1

R1(config-router)#exit

5. Configuration Verification

Check the routes of other routers. If the route of the external network 10.1.2.0/24 can be learned, the redistribution configuration is correct.

 


04 Summary

Features:

The routing summary function of rip can summarize the detailed routes learned by rip or generated by itself and then pass it to rip neighbors, reducing the routing entries of routers.

Application scenario:

There are many IP network segments in the enterprise network. In order to reduce the routing entries on the router and improve the performance of the router, you can configure route summarization on the router.

1. Networking requirements

The detailed routes learned through the rip protocol, in order to reduce routing entries, summarize the detailed routes.

2. Network topology

 

3. Configuration points

1. The ip address and basic rip configuration of the router in the whole network

2. Configure route summary

4. Configuration steps

1. The ip address and basic rip configuration of the router in the whole network

Configuration reference "RIP basic configuration" chapter (typical configuration--->IP routing--->RIP--->basic configuration)

2. Configure route summary

Notice:

1) The route summary of rip can summarize the routes generated by itself or learned from neighbors on the out interface transmitted by any route, and cannot be summarized in supernetwork.

2) Before manually summarizing rip, the automatic summarization function must be turned off .

R1(config)#router rip

R1(config-router)#no auto-summary       //Turn off automatic summary

R1(config-router)#exit

R1(config)#interface gigabitEthernet 0/0

R1(config-GigabitEthernet 0/0)#ip rip summary-address 10.1.0.0 255.255.0.0     // Summarize the route to 10.1.0.0/16

R1(config-GigabitEthernet 0/0)#exit

5. Configuration Verification

Check the routes of the routers in the entire network. If the routers in the entire network have correctly learned the summarized routes, the route summary of rip is configured correctly.

Guess you like

Origin blog.csdn.net/weixin_57099902/article/details/132226646