寻找两个序列的中位数

问题

1029 Median (25 分)
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10
5
) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:
For each test case you should output the median of the two given sequences in a line.

Sample Input:
4 11 12 13 14
5 9 10 15 16 17
结尾无空行
Sample Output:
13

思路

只用一个可变长数组接收这两个序列,然后从小到大排序,最后输出下标为(n+m-1)/2的元素就是中位数。

代码

#include<bits/stdc++.h>
using namespace std;

int main(){
    
    
    int n,m,temp;
    vector<long long> seq;
    cin>>n;
    for (int i = 0; i < n; ++i) {
    
    
        cin>>temp;
        seq.push_back(temp);
    }
    cin>>m;
    for (int j = 0; j < m; ++j) {
    
    
        cin>>temp;
        seq.push_back(temp);
    }

    sort(seq.begin(),seq.end());
    cout<<seq[(n+m-1)/2];
    return 0;
}

总结

这道题我大牙都惊掉了,我看到pat官网的通过率为0.17,说明这题应该是很有难度的。很多大佬的博客包括一些参考书上的做法都是双指针。我用上面的方法3分钟就ac了。真的一脸懵逼,甚至一度怀疑是因为我恰好把所有用例都骗过去了?

Guess you like

Origin blog.csdn.net/qq_19272233/article/details/119464377