FZU2112 Tickets

You have won a collection of tickets on luxury cruisers. Each ticket can be used only once, but can be used in either direction between the 2 different cities printed on the ticket. Your prize gives you free airfare to any city to start your cruising, and free airfare back home from wherever you finish your cruising.

You love to sail and don't want to waste any of your free tickets. How many additional tickets would you have to buy so that your cruise can use all of your tickets?

Now giving the free tickets you have won. Please compute the smallest number of additional tickets that can be purchased to allow you to use all of your free tickets.


Input

There is one integer T (T≤100) in the first line of the input.

Then T cases, for any case, the first line contains 2 integers n, m (1≤n, m≤100,000). n indicates the identifier of the cities are between 1 and n, inclusive. m indicates the tickets you have won.

Then following m lines, each line contains two integers u and v (1≤u, v≤n), indicates the 2 cities printed on your tickets, respectively.


Output

For each test case, output an integer in a single line, indicates the smallest number of additional tickets you need to buy.


Sample Input

3
5 3
1 3
1 2
4 5
6 5
1 3
1 2
1 6
1 5
1 4
3 2
1 2
1 2
Sample Output

1
2
0
answer:

Each time you get an edge, add one to the degrees of both cities, and finally get how many cities with odd degrees there are, because the first city and the last city have pickups, so subtract two, and the number of remaining cities Divide by two to get the result. Note that when there is no city with an odd degree, it directly outputs 0. (To sum up, each city has entry and exit, and tickets are two-way, so as long as the degree is an even number, it is satisfied.)

Code:

#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

int board[100005];

intmain()
{
	int N;
	cin>>N;
	while(N--)
	{
		int n,m;
		memset(board,0,sizeof(board));
		scanf("%d %d",&n,&m);
		while(m--)
		{
			int a,b;
			scanf("%d %d",&a,&b);
			board[a]++;
			board[b]++;
		}
		int sum = 0;
		for(int i=1 ; i<=n ; i++)
		{
			if(board[i]&1)sum++;
		}
		if(sum == 0);
		else
		{
			sum -= 2;
			if(sum)sum /= 2;
		}
		printf("%d\n",sum);
	}

	return 0;
}



Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=326061829&siteId=291194637