HDU - 1260 Tickets (simple dp)

Tickets

 

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 

InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input

2
2
20 25
40
1
8

Sample Output

AM 08:00:40 
08:00:08 AM 

meaning of the questions: n number of people lined up to buy tickets (given back to front), now we have the time to spend these n individual tickets separately and together with the previous one time spent to buy tickets, and asked how long it takes to complete the fastest ticket
. . . Set DP [i] denotes the i-th individual buying time to flower, there is a state transition equation dp [i] = min (dp [i - 1] + alone [i], dp [i - 2] + together [i] )
the initial state, dp [1] = alone [ 1]

#include<bits/stdc++.h>
#define debug(x) cout << "[" << #x <<": " << (x) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_back
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

const int maxn = 2010;
int a[maxn],b[maxn];
int dp[maxn];

int main() {
    int t; scanf("%d",&t);
    while(t --){
        int n; scanf("%d",&n);
        for(int i = 1;i <= n;++ i)
            scanf("%d",&a[i]);
        for(int i = 2;i <= n;++ i)
            scanf("%d",&b[i]);
        dp[1] = a[1];
        for(int i = 2;i <= n;++ i){
            dp[i] = min(dp[i - 1] + a[i],dp[i - 2] + b[i]);
        }
        int ans = dp[n];
        int h = 8,m = 0,s = 0;
        s = dp[n] % 60;
        m = dp[n] / 60;
        h += m / 60;
        m = m % 60;
        if(h < 10) printf("0"); printf("%d:",h);
        if(m < 10) printf("0"); printf("%d:",m);
        if(s < 10) printf("0"); printf("%d ",s);
        printf("am\n");
    }
    return 0;
}

 

Guess you like

Origin www.cnblogs.com/rookie-acmer/p/11258373.html