Running Rabbits HDU - 4452 Analog

Running Rabbits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2086    Accepted Submission(s): 1459

Problem Description
Rabbit Tom and rabbit Jerry are running in a field. The field is an N×N grid. Tom starts from the up-left cell and Jerry starts from the down-right cell. The coordinate of the up-left cell is (1,1) and the coordinate of the down-right cell is (N,N)。A 4×4 field and some coordinates of its cells are shown below:

The rabbits can run in four directions (north, south, west and east) and they run at certain speed measured by cells per hour. The rabbits can't get outside of the field. If a rabbit can't run ahead any more, it will turn around and keep running. For example, in a 5×5 grid, if a rabbit is heading west with a speed of 3 cells per hour, and it is in the (3, 2) cell now, then one hour later it will get to cell (3,3) and keep heading east. For example again, if a rabbit is in the (1,3) cell and it is heading north by speed 2,then a hour latter it will get to (3,3). The rabbits start running at 0 o'clock. If two rabbits meet in the same cell at k o'clock sharp( k can be any positive integer ), Tom will change his direction into Jerry's direction, and Jerry also will change his direction into Tom's original direction.This direction changing is before the judging of whether they should turn around.
The rabbits will turn left every certain hours. For example, if Tom turns left every 2 hours, then he will turn left at 2 o'clock , 4 o'clock, 6 o'clock..etc. But if a rabbit is just about to turn left when two rabbit meet, he will forget to turn this time. Given the initial speed and directions of the two rabbits, you should figure out where are they after some time.

Input
There are several test cases.
For each test case:
The first line is an integer N, meaning that the field is an N×N grid( 2≤N≤20).
The second line describes the situation of Tom. It is in format "c s t"。c is a letter indicating the initial running direction of Tom, and it can be 'W','E','N' or 'S' standing for west, east, north or south. s is Tom's speed( 1≤s<N). t means that Tom should turn left every t hours( 1≤ t ≤1000).
The third line is about Jerry and it's in the same format as the second line.
The last line is an integer K meaning that you should calculate the position of Tom and Jerry at K o'clock( 1 ≤ K ≤ 200).
The input ends with N = 0.
 
Output
For each test case, print Tom's position at K o'clock in a line, and then print Jerry's position in another line. The position is described by cell coordinate.

Sample Input
 
  
4 E 1 1 W 1 1 2 4 E 1 1 W 2 1 5 4 E 2 2 W 3 1 5 0
Sample Output
 
  
2 2 3 3 2 1 2 4 3 1 4 1
Source

The meaning of the question: Now there are two rabbits, the first is at (1,1), the second is at (n,n); the two rabbits have their initial direction W and speed S (S grid/hour), they There is a characteristic of running: when it walks S squares forward, it encounters a wall halfway, then it will turn back and run the remaining S. Each rabbit has a time t and turns left every t hours. When two rabbits arrive at the same coordinates (not counting when they meet on the way, just look at the coordinates at the end of each hour), they will change direction, Become the current direction of the other party, (if a rabbit needs to turn left at this time, this left turn can be omitted);

Idea: Simulate this process. As long as the steering and coordinate changes are written as functions, and the problem of paying attention to the simulation details is not a big problem, see the code for details. After I finished typing the code, it was full of bugs, and it took 10 minutes to adjust it. (Fortunately, the idea is still relatively clear)

Code:

#include <cstdio>
#include <cstring>
#include <cctype>
#include <stdlib.h>
#include <string>
#include <map>
#include <iostream>
#include <sstream>
#include <set>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#include<list>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define lson l,m,rt<<1
#define rson m + 1, r, rt << 1 | 1
#define inf 0x3f3f3f3f
typedef long long LL;
const int N=5e4+20;
const double pi=acos(-1);
char s1[10],s2[10];
int sp1,sp2,T1,T2,n;
int F(char s)//Direction: North N 0, East E 1, South S 2, West W 3
{
    if(s=='N') return 0;
    if(s=='E') return 1;
    if(s=='S') return 2;
    return 3;
}
void K(int &x,int &y,int sp,int &z)//The coordinates change when the rabbit runs for an hour
{
    if(z==0)
    {
        x-=sp;
        if(x<=0) x=2-x,z=(z+2)%4;//This is beyond the boundary, you can understand it by simulating it yourself
    }
    else if(z==1)
    {
        y+=sp;
        if(y>n) y=2*n-y,z=(z+2)%4;
    }
    else if(z==2)
    {
        x+=sp;
        if(x>n) x=2*n-x,z=(z+2)%4;
    }
    else if(z==3)
    {
        y-=sp;
        if(y<=0) y=2-y,z=(z+2)%4;
    }
}
void W(int &x)//Turn left, change direction
{
    x=(x+3)%4;
}
intmain()
{
    while(~scanf("%d",&n)&&n)
    {
        scanf("%s%d%d",s1,&sp1,&T1);
        scanf("%s%d%d",s2,&sp2,&T2);
        int k;
        scanf("%d",&k);
        int x1=1,y1=1,t1=0,x2=n,y2=n,t2=0,f1,f2;
        f1 = F (s1 [0]);
        f2=F(s2[0]);
        //x1, y1, represents the coordinates of the rabbit, t1 represents how long it has run, f1 represents the current direction, and the same is true for x2, y2, t2, and f2.
        while(k--)
        {
            K(x1,y1,sp1,f1);//The first rabbit runs for an hour
            K(x2,y2,sp2,f2);//
            t1++,t2++;//time++
            if(x1==x2&&y1==y2)//Meet
            {
                swap(f1,f2);//Direction swap
                continue;//Do not continue to run the following, must not turn left.
            }
            if(t1%T1==0) W(f1);//Turn left every T1 hour
            if(t2%T2==0) W(f2);
        }
        printf("%d %d\n%d %d\n",x1,y1,x2,y2);
    }
}



Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325971028&siteId=291194637