POU 1029

False coin

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20114 Accepted: 5682

Description

The “Gold Bar”bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

Input

The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: ‘<’, ‘>’, or ‘=’. It represents the result of the weighting:
‘<’ means that the weight of coins in the left pan is less than the weight of coins in the right pan,
‘>’ means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
‘=’ means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

Output

Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

5 3
2 1 2 3 4
<
1 1 4
=
1 2 5
=

Sample Output

3

Source

Northeastern Europe 1998

meaning of the title

​ Give you n coins and k groups of weighing results. One of the n coins is fake, its weight is not the same as the others (don't know the size), the real coins are all the same weight. The first number in each group represents the number of coins placed left and right, followed by the number of the coin, and the symbol behind each group is the weighing result. Ask if you can determine which one is the counterfeit currency, if you can't output 0.

Problem solving ideas

​ Since the data is relatively small, I thought of the violent solution at the beginning. If the weighing result is an equal sign, then all coins on both sides are true. The question remains, how to find the fake among the remaining coins. There was no idea at the beginning, but after a few more sets of data were listed, the problem was found. The number of counterfeit coins must be equal to the number of non-equal signs, and the counterfeit coins must all appear on the same side, so it is easy to judge by using an array to record the number of times they appear on both sides. If there are multiple coins that appear the same number of times as the non-equal sign, and it is impossible to directly judge whether they are true or false, then output 0 directly.

code show as below

#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
#define maxn 1005

int weight[maxn],l[maxn],r[maxn],flag[maxn];
int main()
{
//    freopen("in.txt","r",stdin);
    memset(weight,0,sizeof(weight));
    memset(flag,0,sizeof(flag));
    int n,k,ans=0;
    scanf("%d%d",&n,&k);
    for(int i=0; i<k; i++)
    {
        int num;
        scanf("%d",&num);
        for(int j=0; j<num; j++)
            scanf("%d",&l[j]);
        for(int j=0; j<num; j++)
            scanf("%d",&r[j]);
        char t;
        getchar();
        scanf("%c",&t);
        if(t=='=') for(int j=0; j<num; j++)
                flag[l[j]]=flag[r[j]]=1;
        else if(t=='>')
        {
            ans++;
            for(int j=0; j<num; j++)
            {
                weight[l[j]]++;
                weight[r[j]]--;
            }
        }
        else if(t=='<')
        {
            ans++;
            for(int j=0; j<num; j++)
            {
                weight[l[j]]--;
                weight[r[j]]++;
            }
        }
    }
    int sum=0,cur=0;
    for(int i=1; i<=n; i++)
    {
        if(flag[i]) continue;
        if(weight[i]==ans||weight[i]==-ans)
        {
            sum++;
            cur=i;
        }
    }
    if(sum>1) printf("0\n");
    else printf("%d\n",cur);
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325961531&siteId=291194637