4.6 two pointers:A1029 Median

A1029 Median

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

 


#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=1000010;
//为使代码更加简练,令两个序列的最后都添加一个狠大的数INF,
//这样在two pointers的扫描过程中,就可以在其中一个序列已经扫描完
//但count还没有到中位数的情况下解决访问越界的问题
const int INF=0x7fffffff;
int a[maxn],b[maxn];
int main(){
    int n,m;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&a[i]);
    }
    scanf("%d",&m);
    for(int j=0;j<m;j++){
        scanf("%d",&b[j]);
    }
    a[n]=b[m]=INF;
    int medianPos=(n+m-1)/2;
    int i=0,j=0,count=0;
    while(count<medianPos){
        if(a[i]<b[j]) i++;
        else j++;
        count++;
    }
    if(a[i]<b[j])
        printf("%d\n",a[i]);
    else
        printf("%d\n",b[j]);
    return 0;
}

 

Published 157 original articles · won praise 15 · views 10000 +

Guess you like

Origin blog.csdn.net/nanke_4869/article/details/104626349