POJ - 3273 Monthly Expense Two Points

Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31679   Accepted: 11958

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2.. N +1: Line i +1 contains the number of dollars Farmer John spends on the i th day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source


The meaning of the question: Given N numbers, divide the N numbers into M segments, so that the smallest value in the sum of each segment is the largest in all divisions.
Ideas: two points. The left value is the largest of all, and the right value is the sum of all numbers.


#include<stdio.h>
int money[100005];
intmain()
{
	int N, M;
	while (~scanf("%d %d", &N, &M))
	{
		int left = 0, right = 0;
		int mid;
		for (int i = 0; i < N; i++)
		{
			scanf("%d", &money[i]);
			right += money[i];
			if (money[i]>left)
				left = money[i];
		}
		while (right > left)
		{
			mid = (right + left) / 2;
			int cost = 0, num = 0;
			for (int i = 0; i < N; i++)
			{
				if (cost + money[i]>mid)
				{
					num++;
					cost = money[i];
				}
				else
					cost += money[i];
			}
			num++;
			if (num <= M)
				right = mid;
			else
				left = mid+1;
		}
		printf("%d\n", right);
	}
	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325946731&siteId=291194637