poj3104 Two points

Drying
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20920   Accepted: 5265

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

Source

Northeastern Europe 2005 , Northern Subregion
divide the time to see if it is suitable. If it matches, r=mid-1, continue to look for the smallest one, if not, l=mid+1, look for the larger one, pay attention here, when using the hair dryer, It will not be air-dried naturally, that is to say, if the hair dryer dries k in one minute, then it will not be air-dried naturally in that second. We assume that it is air-dried naturally, then if it is not dry, then To blow it with a hair dryer, c=a[i]-mid, this is the value after natural air drying, suppose we need m seconds to dry it, c-mk+m=0
where mk is the water dried by the hair dryer, + m represents that m seconds have not been naturally air-dried here, so add it, find m, and take the upper bound, you can get the answer, pay attention to the case of k=1, the case of k=1 proves that k does not have any Useful, you can only let it dry naturally, which is equivalent to c-m+m=0 actually does not exist, so it’s fine if it doesn’t match directly
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;
int n;
long long k;
long long a[100009];
int cmp(long long a,long long b)
{
    return a>b;
}
int solve(long long mid)
{
    long long c;
    int i;
    long long ans=0;
    for(i=0; i<=n-1; i++)
    {
        c=a[i]-mid;
        if(c<=0) continue;
        if(k==1) return 0;
        long long l=ceil(c*1.0/(k-1));
        years+=l;
        if(ans>mid) break;
    }
    if(ans>mid) return 0;
    else return 1;
}
intmain()
{
    int i;
    while(~scanf("%d",&n))
    {
        long long C=0;
        for(i=0; i<=n-1; i++)
        {
            scanf("%lld",&a[i]);
        }
        scanf("%lld",&k);
        sort(a,a+n,cmp);
        long long l=1,r=1000000009,mid;
        while(l<=r)
        {
            mid=(l+r)/2;
            if(solve(mid))
            {
                C=mid;
                r=mid-1;
            }
            else l=mid+1;
        }
        printf("%lld\n",C);
    }
}
/*
3
2 3 9
5
3
2 3 6
5
*/


Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324769606&siteId=291194637