PAT-1065 A+B and C (64bit)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line “Case #X: true” if A+B>C, or “Case #X: false” otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

The main idea of ​​the title: Receive three numbers a, b, c, and the value range is [ 2 63 , 2 63 ), it is required to judge whether *a+b>c * holds.

Solution: All three numbers can be stored in long variables. It should be noted that overflow problems may occur, so judgments should be made according to the overflow rules.

  • If a and b are both greater than 0, but the addition result is less than 0, the result overflows, there must bea+b>c
  • If a and b are both less than 0, but the addition result is greater than 0, the result overflows, there must bea+b<c
  • If a and b have different signs, there is no overflow problem, just compare the size directly
#include <cstdio>
int main(void) {
    int t, i;
    long a, b, c, d;

    scanf("%d", &t);
    for (i = 1; i <= t; i++) {
        scanf("%ld%ld%ld", &a, &b, &c);
        d = a + b;
        printf("Case #%d: ", i);
        if (a < 0 && b < 0 && d >= 0) {
            printf("false\n");
        }
        else if (a > 0 && b > 0 && d < 0) {
            printf("true\n");
        }
        else if (a + b > c) {
            printf("true\n");
        }
        else {
            printf("false\n");
        }
    }

    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325935598&siteId=291194637