Til the Cows Come Home POJ - 2387 (shortest path)

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.


Question: Find the shortest path from 1 to point n

Code 1: 79ms

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 1005;
struct node{
	int to;
	int val;
};
vector<node>G[N];
int vis[N],dis[N];
int m,n;
void Dijkstra(int s){
	memset(vis,0,sizeof(vis));
	memset(dis,Inf,sizeof(dis));
	dis[s]=0;
	for(int k=0;k<n;k++){
		int mint = Inf, u = 0;
		for(int i=1;i<=n;i++){
			if(!vis[i]&&mint>dis[i]){
				mint=dis[i];
				u=i;
			}
		}
		vis [u] = 1;
		for(int i=0;i<G[u].size();i++){
			int v=G[u][i].to;
			if(dis[v]>dis[u]+G[u][i].val){
				dis[v]=dis[u]+G[u][i].val;
			}
		}
	}
	printf("%d\n",dis[n]);
}
int main(){
	scanf("%d%d",&m,&n);
	for(int i=0;i<m;i++){
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		G[a].push_back((node){b,c});
		G[b].push_back((node){a,c});
	}
	Dijkstra(1);
	return 0;
}

Code 2: 47ms 

Priority queue optimization

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 1005;
struct node{
	int to;
	int val;
};
struct Node{
	you and;
	int val;
	bool operator < (const Node other) const{
		return val>other.val;
	}
};
vector<node>G[N];
int vis[N],dis[N];
int m,n;
void Dijkstra(int s){
	memset(vis,0,sizeof(vis));
	memset(dis,Inf,sizeof(dis));
	priority_queue<Node>p;
	p.push((Node){s,0});
	dis[s]=0;
    while(!p.empty()){
    	Node temp=p.top();
    	p.pop();
    	int u = temp.u;
    	if(vis[u]) continue;
    	vis [u] = 1;
    	for(int i=0;i<G[u].size();i++){
    		node tem=G[u][i];
    		int v=tem.to;
    		int val = tem.val;
    		if(dis[v]>temp.val+val){
    			dis[v]=temp.val+val;
    			p.push((Node){v,dis[v]});
			}
		}
 	}
	printf("%d\n",dis[n]);
}
int main(){
	scanf("%d%d",&m,&n);
	for(int i=0;i<m;i++){
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		G[a].push_back((node){b,c});
		G[b].push_back((node){a,c});
	}
	Dijkstra(1);
	return 0;
}
Code 3: 79ms 
#include<cstdio>
#include<cstring>
#include<algorithm>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 1005;
struct node{
	you and;
	int v;
	int val;
	int next;
}edge[N*4];
int cnt,head[N];
int dis[N];
int n,m;
void add(int a,int b,int c){
	edge[cnt].u=a; //Starting point
	edge[cnt].v=b; //End point
	edge[cnt].val=c;//Weights
	edge[cnt].next=head[a];
	head[a]=cnt++;
}
void init(){
	memset(head,-1,sizeof(head));
}
void BellmanFord(int s){ //traverse each edge
	memset(dis,Inf,sizeof(dis));
	dis[s]=0;
	for(int i=1;i<=n;i++){
		for(int k=0;k<cnt;k++){
			node temp=edge[k];
			int u=temp.u,v=temp.v,val=temp.val;
			if(dis[v]>dis[u]+val){
				dis [v] = dis [u] + val;
			}
		}
	}
	printf("%d\n",dis[n]);
}
int main(){
	scanf("%d%d",&m,&n);
	init();
	for(int i=0;i<m;i++){
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		add(a,b,c);
		add(b,a,c);
	}
	BellmanFord (1);
   return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325900143&siteId=291194637