suffix array - K longest repeating substrings that can overlap

single 3261

Topic link:  Click to open the link

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least Ktimes.

Input
Line 1: Two space-separated integers:  N  and  K 
Lines 2..  N +1:  N  integers, one per line, the quality of the milk on day  i  appears on the  i th line.
Output
Line 1: One integer, the length of the longest pattern which occurs at least  K  times
Sample Input
8 2
1
2
3
2
3
2
3
1
Sample Output
4


            Question: Find the length of the longest overlapping substring that occurs k times

                Find the k longest repeating substring that can overlap

                analyze:

                    Divide the answer first, then divide the suffixes into groups. The difference is that the judgment here is whether there is a group whose number of suffixes is not less than

                    K, if there is, then there are k identical substrings that satisfy the condition, otherwise it does not exist, algorithm time complexity: O(nlongn)

        

#include <cstdio>
#include <iostream>
using namespace std;
const int maxn = 2e4 + 10;
const int Max = 10000;

int sa[maxn],rank[maxn],height[maxn];
int wa[maxn],wb[maxn],wv[maxn],Ws[maxn];
int num[maxn],s[maxn];

int cmp (int *r,int a,int b,int l){
    return r[a] == r[b] && r[a + l] == r[b + l];
}

void get_sa (int * r, int n, int m){
    int i, j , p, *x = wa,*y = wb,*t;
    for (i = 0; i < m; i++) Ws[i] = 0;
    for (i = 0; i < n; i++) Ws[x[i] = r[i]]++;
    for (i = 1; i < m; i++) Ws[i] += Ws[i - 1];
    for (i = n - 1; i >= 0; i--) sa[--Ws[x[i]]] = i;
    for (j = 1, p = 1 ; p < n; j *= 2, m = p){
        for (p = 0, i = n - j; i < n; i++) y[p++] = i;
        for (i = 0; i < n; i++) if (sa[i] >= j) y[p++] = sa[i] - j;
        for (i = 0; i < n; i++) wv[i] = x[y[i]];
        for (i = 0; i < m; i++) Ws[i] = 0;
        for (i = 0; i < n; i++) Ws[wv[i]]++;
        for (i = 0; i < m; i++) Ws[i] += Ws[i - 1];
        for (i = n - 1; i >= 0; i--) sa[--Ws[wv[i]]] = y[i];
        for (t = x, x = y, y = t,p = 1, x[sa[0]] = 0, i = 1; i < n; i++){
            x [sa [i]] = cmp (y, sa [i - 1], sa [i], j)? p -1: p ++;
        }
    }
}

void get_height(int *r,int n){
    int k = 0, j;
    for (int i = 1; i <= n; i++) rank[sa[i]] = i;
    for (int i = 0; i < n; height[rank[i++]] = k){
        for (k ? k-- : 0, j = sa[rank[i] - 1]; r[i + k] == r[j + k]; k++);
    }

}

bool f (int n, int k, int x){
    for (int i = 2; i <= n; i++){
        if (height[i] >= x){
            int cmt = 1;
            for (i; i <= n && height[i] >= x; i++) cmt++;
            if (cmt >= k) return 1;
        }
    }
    return 0;
}

int solve (int n, int k){
    int years = 0;
    int ls = 0, rs = n;
    while (ls <= rs){
        int mid = (ls + rs) / 2;
        if (f(n,k,mid)) ans = mid, ls = mid + 1;
        else rs = mid - 1;
    }
    return ans ;
}

int main(){
    int n , k ;
    scanf("%d%d",&n,&k);
    for (int i = 0 ;i < n; i++){
        scanf("%d",&num[i]);
    }
    num[n] = 0;
    get_sa(num,n+1,Max);
    get_height(num,n);
    for (int i = 0; i < n; i++){
        printf("height - > %d ",height[i]);
    }
    printf("%d\n",solve(n,k));
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325884944&siteId=291194637