HDU - 1004 Let the Balloon Rise (use of map)

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

Problem solving ideas:

The use of map container, < key , value > in map corresponds to <balloon color, number of balloons> in this question.
For a detailed explanation of the map, see:

Code:

#include <iostream>
#include <cstdio>
#include <string>
#include <map>
using namespace std;

map<string , int > balloon;
int main(){
    //freopen("D://testData//1004.txt" , "r" , stdin);
    int n;
    int i;
    string bal;
    while(cin>>n && n){
        balloon.clear();   //清空上一次的数据

        for(i = 0 ; i < n ; i ++){
            cin>>bal;
            balloon[bal] ++;
        }

        map<string , int>::iterator it;    //迭代
        string maxColor;
        int max = 0;
        for(it = balloon.begin() ; it != balloon.end() ; it ++){
            if(max < it->second){
                max = it->second;   //对应 value(气球的数量)
                maxColor = it->first;   //对应 key(气球的颜色)
            }
        }

        cout<<maxColor<<endl;
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325858081&siteId=291194637